Alteryx Server Knowledge Base

Definitive answers from Server experts.

Alteryx Service Error - “Input string was not in a correct format”

JakeS
Alteryx Alumni (Retired)
Created

Alteryx Service Fails to Start when Mongo Fails with Error - “Input string was not in a correct format”

 

When trying to start the Alteryx Service, the following error can be seen in the Alteryx Service or Gallery Logs:

 

FATAL,1,,RegisterClasses,,,,Axx-xxxxx100,,,,,,Input string was not in a correct format.,

 

Environment

 

  • Alteryx Server
  • Windows Operating System

 

Diagnosis

 

This error message is coming directly from MongoDB and while very generic, it is telling us that the driver is unable to handle the data that is being sent to MongoDB. The Alteryx Service will fail to start and you will most likely get some sort of popup error when trying to start the service from the Windows Services menu.

 

Is FIPS enabled on your machine? If so, See Solution A.

 

Are you in a multi-node environment? If you are unable to start the Alteryx Service on a node that isnot the Controller, see Solution B.

 

Cause A

 

FIPS is enabled on the Machine

 

Solution A

 

This error occurs because the encryption Alteryx Server uses for inter-service communication won't happen if FIPS is enabled because .NET will block the requests.

 

The Alteryx Gallery uses .NET completely for communication with MongoDB, there is not another option for communication.

 

Resolutions\Workarounds

There is currently no workaround to get the Alteryx Service to start with FIPS enabled. FIPS must be disabled completely on the server machine to get the Alteryx Gallery to communicate with Mongo correctly and get the service running. The impacted policy is named System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing.

 

To get to this setting:

 

1. Open the Local Security Policy window from the Windows Start menu

2. Navigate to Local Policies> Security Options

3. Select the correct policy

FIPSpolicy.png

 

Make sure that group policy does not enforce FIPS after reboot. To verify that FIPS has been disabled, make sure that the “Enabled” registry key located here HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\FipsAlgorithmPolicy is set to “0”:

 

FipsRegedit.png

 

Cause B

 

Generic failed Connection to MongoDB (Not FIPS).

 

Solution B

 

The error states that for whatever reason, MongoDB is not able to understand the information that is being sent. A failed connection to MongoDB can also cause this error, though it can be difficult to pinpoint the root cause. There are a few things that you will want to check to see if they are causing the issue:

 

1. If you have a multi-node environment and are configuring the Gallery, confirm the following in the Alteryx System Settings under Gallery >Persistence.

1. Confirm the password is correct. This password should be the user (not-admin) password from the System Settings on the Controller.

2. Confirm you have the port appended to the hostname (default port for embedded MongoDB is 27018)

hostname:port

 

2. Enable Mongo logging and see if MongoDB gives more details on why the error is occurring

3. Test connecting to MongoDB through another source (such as Robo 3t) and see if this gives more detail on why the error is occurring.



Additional Resources

No ratings
Comments
levell_x_dunn
9 - Comet

Good Afternoon,

 

We are seeing the same error message though our FIPS is already disabled and it's a single node. 
mongo also connects via Robo3t

 

The ticket has been open and number: 00341900

 

levell_x_dunn_0-1589227953844.png