community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

workflow exceeded maximum runtime of 30 seconds and was cancelled.

Fireball

I just upgraded to 10.5 and I get this error in Server:

workflow exceeded maximum runtime of 30 seconds and was cancelled.

App is designer works fine, no events are happening. Solutions center at Inspire16 told me it's a new restriction in 10.5 and it's related to chained apps but nothing more...

I ran a performance profiling on the tools in my app to see if I have bottlenecks. I have an input tool that runs the longest (7.5 secs) which doesn't seem unreasonable. My input connects to sql server and pulls down 8 recs. It uses 64bit ODBC Driver version: 03.80.

 

Has anyone ran into this? Can I change this 30 second threshold in a secret xml file somewhere?

If you have access to the system settings on the server, I believe there is an option under the General settings of the worker. Here's what I seeUntitled2.png

 

Let me know if that doesn't do the trick!

Fireball

Thanks for the feedback - that setting is not enabled on our server, just like yours.

Bummer, I can't think of anything else to check.

Fireball

no problem - Have you ever looked at the list in 'Uninstall Programs' inside Programs & Features? I had some lingering 8.6 web installs. I decided to uninstall anything 'Alteryx', reboot the server, and start with a fresh install. Maybe that will work. Thanks for that tip @ScottJ

We've only been with the server since 9.5 so we didn't have any lingering pieces.

Fireball

For those interested - it IS related to 10.5 AND chained apps. This worked for me, so if you run into the same issue, check this out ~ courtesy Alteryx.

Please make sure you create a backup of this config file before editing it!

 

It turns out that there is an unexposed setting for this.  In the [AlteryxInstallFolder]\bin\config folder there is a file called alteryx.config.  In that file is a section that looks like this:

 

  <engine enableAutoLicensing="true" useServiceLayerComposer="true"

    secret="38C82F8D2643138C3DDD9B8A45E82D02C31E0D5D"

    server="Cloudservice.extendthereach.com">

    <!--mapSubdomains>

        <mapSubdomain subDomain="map1.alteryx.com"/>

        <mapSubdomain subDomain="map2.alteryx.com"/>

        <mapSubdomain subDomain="map3.alteryx.com"/>

      </mapSubdomains-->

  </engine>

 

That engine tag supports an attribute called chainedTimeout which can be set to the number of seconds you want to give each app in the chain before the last app.  To set it to one minute, it would look like this:

 

  <engine enableAutoLicensing="true" useServiceLayerComposer="true" chainedTimeout="60"

    secret="38C82F8D2643138C3DDD9B8A45E82D02C31E0D5D"

    server="Cloudservice.extendthereach.com">

    <!--mapSubdomains>

        <mapSubdomain subDomain="map1.alteryx.com"/>

        <mapSubdomain subDomain="map2.alteryx.com"/>

        <mapSubdomain subDomain="map3.alteryx.com"/>

      </mapSubdomains-->

  </engine>

 

It's all about the tags! :)

Meteor

Hi Simon,

 

We use chained apps more often in our company.

A few of the apps would time out after 30 seconds every now and then, but we would just re-run it again and it would work.

But it has become annoying and end users wanted a more robust execution.

 

Your fix sounded really promising and we did add that chainedTimeout attribute and set it to 120 seconds.

Unfortunately, this did not have any effect and the app still times out after 30 seconds.

 

Is there an additional step for this attribute to take effect?

Fireball

Hey Anand,

 

Sorry to hear - maybe increase from 120? Have you debugged/run 'Performance Profiling' to see if your workflow/macro has a bottleneck?

 

/S

 

PerformanceProfiling.JPGPerformance Profiling

Meteor

Thanks Simon. Performance profiling did help identify the bottleneck. And kind of solved our problem.

But, it still doesnt make sense as to why that timeout parameter doesnt have any effect.

 

Thanks again!!