Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

workflow exceeded maximum runtime of 30 seconds and was cancelled.

@simon Thanks so much for following back up with that solution! We just came across the same problem and your solution fixed the problem after we restarted the alteryxservice on our server.


@anand In case you haven't tried it already, restarting the alteryxservice was necessary before the change took effect. That config file must only be loaded up when the service first starts. 


you are welcome. Just remember that you may have to edit this file again AFTER you perform an Alteryx Server upgrade because this file will get overwritten. I just found that out and I had to look for my own post again. ;) So add this to your to-do list! 





Why?! Why is this the "answer"? :)


I can't understand why we'd want the server to limit chained apps to 30, 60, 120, .... seconds at all. Can't it just use the same defaults set for all apps/workflows?

We are running into the similar issue and we trie to change the alteryx config file but we are still facing the same issue , this option is not working for us is there any another setting we need to change in order to make it work


Our problem is we have a large excel file that we are processing in a chained app and step one runs fine but fails on step2  


@andysokol - Does a shorter chained app work? Just trying to see if the issue is truly the timeout issue.


Also, see here for some other issues with chained apps that you can check to see if you're hitting a 'known' issue:**bleep**/m-p/37...


I found that if the second app was using user supplied credentials, it did not run at all ... :(

Hi, @c2willis


Yes the second app works fine with a smaller excel file and it also works good with CSV files or text file , it stops to work when we have bigger excel files. Below are the issue details 

The job  Data Mapping did not complete successfully and resulted in the following errors:

  • Workflow exceeded maximum runtime of 30 seconds and was cancelled.


I already tried updating the alteryx.config file by adding chainedTimeout="3600"  and still i am getting the error above . So not sure at this point what setting i can change to make chained app work more then 30 second , my excel file has 400K records.


One thing i am about to try is restarting the alteryx service on the server after the setting change.


I restarted the alteryx service on the server based on @patick_digan suggestion and the issue is gone now


I think we did have to restart the server.


This message also seems to happen when the expected data that drives a process is not in the expected format.    In my case I was getting the error when I was trying to execute an app.  This app requires the upload of one TEXT formatted Account ID in Excel.   The user that had the error was trying to upload this ID as a NUMBER.   It seems as well that the user had highlighted the entire column ( so not sure if it was considering for upload all blank rows in such highlighted column).  Perhaps those extra blank cells and not the type was the culprit.


I fixed it by switching the Numeric ID column to TEXT via Text to columns in Excel, then copying and pasting the cells with actual values ( not the entire column) to a new worksheet.  Upon using the new worksheet the app worked as expected and no error was returned.   Excel can be so picky!