We're excited to announce that we'll be partnering with Credly starting October 19th - see what this means and read the announcement blog here!

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

"Others may download this workflow" functionality

Garrett
11 - Bolide

So I've published an app to my company's Gallery. Then I disable "Others may download this workflow" from Workflow Settings. Lastly I share the app out via a Collection.

 

Now I want to update the app. From Alteryx Designer I navigate to the app on the Gallery via File>Open Workflow. The app and the "Open" button are grayed out. And I a little pop-up says "This workflow cannot be opened because the owner has disabled download".

 

But I am the owner! Shouldn't I be able to open the app from Gallery into Alteryx Designer for modification? Shouldn't other Artisans in my same Private Studio also be able to open the app from Gallery into Alteryx Designer?

 

A workaround exists by clicking "Versions" and then double-clicking on the the app version I want to open. But this seems a little "backdoor", especially because the "Open" button here is still grayed out.

 

Am I missing something? Is this expected functionality? Is there a better way to prevent Gallery users from downloading the app while still enabling owners to open and modify it in Alteryx Designer as needed? Thanks!

 

 

7 REPLIES 7
andrewdatakim
12 - Quasar
12 - Quasar

Hi @Garrett.,

 

THis is typically the way you would block other users outside of your Private Studio from being able to download the workflows. I ran a test on version 2020.2.3 and it is not exhibiting the behavior that you are talking about. What version and build of Designer and Server are you on?

Garrett
11 - Bolide

@andrewdatakim:

 

I'm running Server v2020.2 and can replicate from Designer v2020.2 and v2018.4. Interestingly, I can even replicate when publishing to gallery.alteryx.com (rather than to my own private Gallery).

 

Alteryx CS reported they also couldn't replicate. Very odd - not sure whats causing it so that I can't check out my own workflows...

Garrett
11 - Bolide

Update: behavior I see is different depending on whether I leave the drop-down set to “All Locations” versus changing it to “My Private Studio”.

  • All Locations – functions as desired/expected and I can open my own workflow.
  • My Private Studio – bug is present, app is greyed out, and I can not open my own workflow from the list.

 

 

andrewdatakim
12 - Quasar
12 - Quasar

@Garrett,

 

Have you done any editing to your Mongo environment related to your User Profile or have you ever adjusted the authentication type after your user was already added? That was the other most common way I have seen for issues like this. I am wondering if your account got corrupted at some point which is messing with your permissions. Are you having any issues downloading others workflows?

Garrett
11 - Bolide

@andrewdatakim- the MongoDB instance is pristine and authentication has been locked in since initial install/config. Issue doesn't seem specific to any user, studio, or workflows. In fact I can replicate this behavior on gallery.alteryx.com in addition to my own private server.

 

Are you able to replicate the behavior I noted back on 9/11?

 

All Locations – functions as desired/expected and I can open my own workflow:

Garrett_0-1605109793676.jpeg

 

My Private Studio – bug is present, app is greyed out and I can not open from this list:

Garrett_1-1605109793687.jpeg

andrewdatakim
12 - Quasar
12 - Quasar

Hi @Garrett ,

 

I have tried 3 different Galleries and 2 different versions of Alteryx without being able to replicate the issue. I am thinking it may have to do with your Alteryx Designer if it is experiencing the same issue on both your private server and the public Gallery. Do you have another computer or access to the server where you can log in and check just accessing the menu?

Garrett
11 - Bolide

Yup I can replicate from different Designers.

 

I wouldn't bother spending any more time on this. Such a minor thing with at least a couple workarounds...