Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!

Workflow stuck in validation while saving to gallery

yashwanth95
6 - Meteoroid

I have use case saved successfully in Alteryx Gallery for DEV environment and I tried to do the same approach to save in PROD environment Alteryx Gallery and it stuck in the validation part. While running the workflow in PROD local environment, it ran successfully. Can anyone help me out.

c-lopez
Alteryx
Alteryx

If the workflow is successfully verified but not pushed it might be an issue of VPN, your dev and prod environments might be on different networks and you might not be able to push to the prod server unless you are VPN'ed to the same network as the server.

Can you please verify this and try again?

yashwanth95
6 - Meteoroid

Both the networks are VPN'ed. I don't know why it's coming. The same workflow I had saved in the gallery earlier and now made some changes to it tested in the DEV environment gallery. With success note tried to save in the gallery and getting this issue.

raychase
9 - Comet

My understanding is that the 'validation' step is equivalent to manually running the workflow on the Alteryx Server as the configured run-as user.  As such, it is very much a possibility that the validation could be queued up behind actively running jobs.  This would effectively delay your verification.