Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
It's the most wonderful time of the year - Santalytics 2020 is here! This year, Santa's workshop needs the help of the Alteryx Community to help get back on track, so head over to the Group Hub for all the info to get started!

Wait a second macro

Highlighted
8 - Asteroid

When i run the workflow that include a wait a second marco in place and it works correctly but as soon as i put the workflow on a schedule i am getting the following error

 

00:15:15.173 - ToolId 267: D:\AlteryxWorkflow\Macros\InvisoMacros\InvisoMacros\Macros\AssistingMacros\temp.yxdb|Record #1: Tool #1: 1 records were written to "D:\AlteryxWorkflow\Macros\InvisoMacros\InvisoMacros\Macros\AssistingMacros\temp.yxdb"

03:00:15.337 - Error - ToolId 265: The field "RecordID" is not contained in the record.

 

It seems that wait a second marco it stopping anything been past though but it seems odd as i have another workflow on schedule that run daily that contains the same wait for a second macro but don't get me this error.

 

Any advice on how i can get this to work?

 

 

 

 

Highlighted
Alteryx Community Team
Alteryx Community Team

@AndrewCrayford ,

 

I would recommend attaching the workflow to the post. It will be difficult for the Community to assist without seeing the setup of the workflow. It also looks like you have errors coming from other tools. Do you believe that error is a result of the wait a second macro or could there be a setup issue which is causing the errors?

 

DanM