alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

US Geocoder problem

9 - Comet

I'm not sure this is the appropriate place to post this. If you deem that it isn't, I hope you can move it to the appropriate place. This problem first appeared to be a Gallery/Server problem, but later revealed to be bigger.


I have this simple workflow that worked perfectly in Designer:

geocode workflow.gif


When I went to publish it to server, I received the error:

geocode save error.gif


Interestingly, when scheduling the workflow, it still completed successfully, in spite of the log entry which shows the same error. But the results appeared in the output table as expected.


When executing the workflow from the gallery, the same error appears, but again, the results appeared in the output table as expected.

geocode workflow error.gif

Until this point, the problem appeared to be entirely Alteryx Server related. However, when I added an Event in Designer to send an email on run with errors, Designer still completed, showing no errors.

geocode workflow no error.gif


But I received an email with the same error:



Started running E:\ProgramData\Alteryx\Engine\Staging\977eb6df-ca95-4695-a2b5-f14e81cc8bdb\New Addresses - Geocode and append.yxmd at Wed Jul 12 15:00:17 2017

00:00:0.156 - Error - ToolId 228: Macro Input cannot be used as a question input for this action type.



So, I opened the US Geocoder macro and searched for tool 228. That tool is a simple Select tool which has no direct connection to any type of interface tool. This error doesn't make any sense to me. Is there a bug in the US Geocoder or not? 


Can anyone reproduce this problem? Any help would be greatly appreciated. Thank you for your help!

5 - Atom

I have a very similar workflow. Same error message when uploading and when running on the server. However, it completes successfully despite this error. No error message on the desktop like you. I'd imagine it's stemming from the geocoder. 


Hi @blyons


Which vintage of the geocoder are you on? I'm unable to replicate using 2017_Q1.


I also noticed in the log that no records were read in and no records were written out. I wonder if the lack of data is keeping the macro from configuring correctly.

7 - Meteor



I'm having a similar issue were you able to resolve this issue running on Server? Error below occurs when running workflow on server and no error while just running in designer.

Error: Tool #227: Macro Input cannot be used as a question input for this action type.

Thanks in advance.

Alteryx Partner

Same issue here. Using Alteryx Designer 2018.4.5.55178 with Geocoder 2018 Q3 in Allocate Append. I'm using Desktop Scheduler and hit the same error. Hadn't checked to see if it output correctly before re-running manually.

7 - Meteor



I believe there is a defect that Alteryx dev team is working on also they've suggested that randomly, yet infrequently, could work around the issue by adding tools to the workflow and resaving to the gallery (Selects, Browses, Data Cleanses, etc. - essentially using them as pass through tools).


Hope this helps.