Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Scheduling a Workflow Containing Macro on Server

9 - Comet



We are just now getting a server environment set up. I am trying to schedule a fairly basic workflow on the server using the controller from my laptop. 


I have the drive mapped on the server where the macro is located, and have tried a couple of local locations for hosting the macros as well(I mapped them in using the User Settings). However, whenever I schedule my workflow, it tells me that it cannot find my macro file. 


Any thoughts on how I can get the server to use my macro from the shared drive when I publish the workflow to server? 


FYI, the macro I created is a knockoff of the publish to tableau so our team could easily switch between out Prod/Dev/QC environments using our functional ID without having to create a new tool or go looking around for the url. 


Thanks for any help! 

9 - Comet

I sort of figured it out. When I saved it to the gallery(We still aren't sure how we are going to keep all of our workflows organized) It messed up all of my dependencies. When I scheduled from the version saved to my hard drive, everything worked great. I believe if I saved without the assets selected, it may solve this issue. 

16 - Nebula
16 - Nebula

I have several apps published to the Gallery with Macros and other data on shared drives.  You are correct - unselect the assets during the publishing routine and the app in the Gallery will get them from their location.

6 - Meteoroid

I have just started using the Alteryx Server and Scheduler and am running into issues with file path issues.

The problem that I would currently like some help with is around scheduling a workflow with a macro in it. My macro is saved on the server in a folder intended to hold everyone's macros. My installation is pointed at that macro folder as the 'Macro Repository' as recommended in the help pages. The installation that runs on the server is also pointed at that same macro folder as it's default (and only) macro repository. I can run the macro without errors from either my machine, or the server's installation, but when scheduled, I get an error that the macro can not be found. Do I also need to somehow point the scheduler (controller) at that 'macro repository', or am I doing something else wrong? In all cases, if I eddit the XML and fill in the full file path, it works fine from all machines and the scheduler.

Thank you for your help. ~Joren

7 - Meteor

We were experiencing a similar issue with Macros and Server.  We met with Alteryx Support and discovered that the Workflows with embedded Macros would run if the following conditions existed:


  • Both the Workflow containing the Macro and the Macro were saved in the same file folder prior to publishing to Server
  • The file paths were checked to All UNC filepaths in the Workflow Dependencies


Not sure if this helps, but try it out.