Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

SQL Server 2019 Upgrade

8 - Asteroid

We have updated one of our SQL servers to SQL 2019 and disabled TLS 1.0 and 1.1 which has caused one of our Alteryx workflows to break. We have an input tool connected the SQL server 2019 via an OleDB connection which throws the following error:


Error: Input Data (1): Error opening connect string: Microsoft OLE DB Provider for SQL Server: [DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security error.\08001 = 18


I thought this might be caused by an outdated driver so I installed


Microsoft OLE DB Driver for SQL Server (MSOLEDBSQL):


on the Alteryx Server but I still get the same error. It seems to run fine locally from designer. Any suggestions? 

17 - Castor
17 - Castor

Hi @bjschwartz3 


Which version of Alteryx Designer (local) and Alteryx Server are you using?


8 - Asteroid

We figured it out. I had to configure the input/output tool differently than normal. I had to select 'Microsoft OLD DB Driver for SQL Server' instead of 'Microsoft OLE DB Provider for SQL Server'. Now I just need to figure out how to change the default selection.

7 - Meteor

We were facing exact same issue. Thank you for posting the solution, it helped us.