Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

Microsoft Power BI Output Tool - Error Message for authentication

Highlighted
5 - Atom

Hi all,

I want to run an Alteryx Workflow in the Gallery. The workflows ends in writing Power BI data direct into Power BI. It works on the local machine and does not work in the Gallery. When running the workflow, it throws me these errors:

 

The job New Workflow7 did not complete successfully and resulted in the following errors:

  • Failed to decrypt value for clientSecret! (Tool Id: 2)
  • Failed to decrypt value for password! (Tool Id: 2)
  • Please enter a client secret (Tool Id: 2)
  • Failed to decrypt value for accessToken! (Tool Id: 2)
  • Please log in (Tool Id: 2)

While I understand, that it has something to do with the Authetification, I do not know how to bring all keys and passwort into the Gallery. Had anyone else this experience?

 

Thanks

Highlighted
Alteryx
Alteryx

Hi @alexi2019 

 

This is a known issue with the Publish to Power BI connector.  Our development team is aware and working to resolve the connection issue.  There currently is not a workaround. 

Highlighted
5 - Atom

Matt,

 

I'm seeing similar errors here working with the OneDrive input/output tool publishing to Alteryx Server. When I run the flow locally, it runs fine, however when I publish to server I'm seeing:

 

[filename] Tool 9 - Failed to decrypt value for od_ClientSecret!

[filename] Tool 9 - Please enter a Client secret

[filename] Tool 9 - Failed to decrypt value for od_AuthToken!

[filename] Tool 9 - Please log in

 

Is this PowerBi Connector issue the same bug as the integration with your OneDrive input/output tool? If so, any idea when this bug will be patched or a workaround provided?

Highlighted
7 - Meteor

I have the same issue with OneDrive - did you manage to make it work?

Highlighted
5 - Atom

Veruzi,

 

The good news is yes, we were able to get to a workable solution to resolve this problem. We created a ticket through Alteryx support (e-mail support@alteryx.com) and they reconfigured some settings on our Alteryx server instance as well as my local machine.

 

Definitely recommend you starting a ticket through their support team and reference this thread so they can walk you through the server reconfig steps. Also, feel free to reach back out to me if the support rep you're working with needs additional context or direction from our rep.

 

Highlighted
7 - Meteor

Thank you Patrik!

I've already opened a ticket with the Support team and we'll be meeting tomorrow to apply the workaround 🙂