Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
The Expert Exam is now live online! Read about the specifics and what it took to bring it to life in the blog by our very own Elizabeth Bonnell!

Map showing polygon reference file as analytic app, but not in server gallery

Highlighted
Alteryx
Alteryx

Hi @KHoward,

 

I will check to see what additional information we can provide.  I don't have any timeline information currently but I will check with the teams here at Alteryx.

 

Thanks for following up,

Jess Silveri
Premium Support Advisor | Alteryx
Highlighted
Alteryx
Alteryx

Hi All,

 

We are still working to get an update on this issue and will post back as soon as we have this information.

 

Thanks,

Jess Silveri
Premium Support Advisor | Alteryx
Highlighted
Alteryx
Alteryx

Hello,

 

This issue is in our development team's queue for prioritization.  At this time they do not have a schedule date available but we have noted the priority request from several users on this thread and will do our best to prioritize it accordingly.

 

We appreciate everyone following up and will post back when we do have a date available.

Jess Silveri
Premium Support Advisor | Alteryx
Highlighted
11 - Bolide

@JessicaS

Thank you for keeping this discussion alive.  Getting this fixed would be major.  I have a reference file that gets updated nightly, by workflow scheduled in Gallery, so it's frustrating that it can't just stay attached to an app on Gallery

 

Of the apps I've created and published to our company Gallery, the ones with a map interface get the most traction and acceptance from our user base.  (And lead to new requests for apps, which is great.)

 

See you at #alteryx19, I hope.

 

 

Best,

David

 

Highlighted
Alteryx Certified Partner

Any update here? I have found the same issue currently with 2019.1. 

Highlighted
10 - Fireball

I got an email a few months back saying that they had fixed this bug, but I haven't tried it again (gave up on that functionality and kept going with the workaround).

 

Currently doing some upgrade work on my server, but when it's back up I'll give it a try with 2019.2

Highlighted
10 - Fireball

It looks like it's working again for me:

 

workflow.PNG

 

 

 

And then when I put that to the server the reference map shows up prior to running.

server workflow.PNG

Highlighted
Alteryx Certified Partner

It appears that you are attaching the reference map when pushing it to server (judging by the _externals folder in the map input tool). What about when you submit without attaching the reference map layer as an asset?

Highlighted
10 - Fireball

You're right I did that a little too quickly. I saved that same file on Dropbox and unchecked that file when saving to the server, so hopefully it should look for that reference file.

 

It doesn't show when run locally as an analytic app or through the browser on the server. It seems that the map has scaled correctly (way out because I'm using a whole north america polygon set), but no actual polygons display.

 

Looks like this hasn't actually been solved...

Highlighted
5 - Atom

Do we have any updates on this? Any workaround? Was it accepted as a bug?

We're running on 2019.4 and experiencing the same issue.