Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

MY SQL Data Source based workflows failing after migration to 2020.4.5 Gallery

srikant96
8 - Asteroid

Other than simple query with the input tool , most others failing with the following message 

srikant96_0-1620258893191.png

I thought I will just remove the so called input tool 30 ( reading from MY SQL with DSN connection sitting in my desktop as well server) to a separate workflow by itself . It went thru fine . no issues . I tried to delete this tool and copy paste other working tool and just substitute the SQL , still no luck 

6 REPLIES 6
danilang
18 - Pollux
18 - Pollux

Hi @srikant96 

 

Bugs like this need to be looked at by the Alteryx support team.  Contact them at support@alteryx.com 

 

Dan 

srikant96
8 - Asteroid

Its been more than a week . Support team did not return my call/email. meanwhile , my research suggested that SQL driver version could be the issue . version out of sync in server compared to my latest version desktop . After making sure both versions are same and re doing those connections ion workflows...seems to be stable  now . not out of the woods yet

ntobon
Alteryx
Alteryx

This could be a ODBC driver compatibility issue. Please review the following Knowledge Base article:

https://community.alteryx.com/t5/Alteryx-Server-Knowledge-Base/Error-quot-You-have-found-a-bug-quot-...

 

Help: https://help.alteryx.com/current/designer/mysql

Validated On:
Database Version: 8.0.19
ODBC Client Version: 1.00.19.1021

 

What driver version do you have?  If you are not using the supported driver version please install it and test it again.

srikant96
8 - Asteroid

I got a reply from Alteryx Support as well that I must revert to 8.0.19 from 8.0.24 . But few things are not clear . What is this  - ODBC Client Version: 1.00.19.1021 ?
 

I thought I need same ODBC MY SQL driver version 8.0.19 and that's what I have and it' s working fine for all desktop connection 

 

And meanwhile my workflows are failing randomly instead of failing consistently . Will go thru one day fine and next day it will fail  and most of the time data output is complete but still the bizarre error comes 

 

Does it mean I have to re do my connections and publish workflows again ? ( some of them i did anyway. but no luck still ) 

 

and  what is this ODBC version that shows up in log of a workflow after its done running ?

 

Message Type Process or Tool Id Details

 

Information -1 Running at a Low Priority.
Information 1 ODBC Driver version: 03.80

 

Thanks 

ntobon
Alteryx
Alteryx

@srikant96  

1.00.19.1021 is the supported simba driver version. 
srikant96
8 - Asteroid

Thank You . the worker nodes also required update and that was the last link failing . In good shape now . the magic is 8.0.19 on all nodes ( server, worker etc)