We have extended our Early Bird Tickets for Inspire 2023! Discounted pricing goes until February 24th. Save your spot!

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Licensing portal very slow

RoelEsselink
8 - Asteroid

This a a message to all license administrators who use licensing.alteryx.com to manage their license usage. For me ever since they moved to this third party licensing portal it has been insufferably slow for me. I am talking about a minimum 10+ seconds loading time for every action and page load on this site. I've raised this as an issue with Fulfillment but for them it is not an issue they say.

 

Below is what I measured with a stopwatch today (it was very slow today):

Logging in: 57 sec / 1min16sec

Loading Administer Machines page: 1m33sec
Clicking on Machine Name (which loads Overview page): 14 secs
Loading next page on Administer Machines page: 46 secs

 

I just wanted to poll other users of this portal here to see what performance for them is like.

5 REPLIES 5
JosephSerpis
16 - Nebula
16 - Nebula

Hi @RoelEsselink I agree it's slow the explanation I've heard is the license portal sever is based in the US so there is lack due to having to connect to the US. 

RoelEsselink
8 - Asteroid
Well that might be true but it's not acceptable. I will raise it again as an issue then. Especially since the it's the only way to extract license usage data. Extract meaning manual copy and paste of every page of course as it does not have an export functionality!
yuriy
8 - Asteroid

Do not accept the answer for servers being in US. I am in the US, and this portal is super slow. The whole interface looks like from 1990s. We have recently started working with Alteryx, but every time I need to view/manage users/licenses, it is a nightmare. Have to sit and watch that platform is spinning. I understand this is a third party product, but that means that Alteryx has to push harder on that product to make it more usable or find another partner.

CatheyH
8 - Asteroid

I have found some ways of speeding this up but is very manual, and frustrating.

1) Make sure that all users have a Surname in your AD files. Service Accounts in particular may not have one included and this is a required field. You may need to do this through the MongoDB.

2) Set any users that have left the AD Group to "No Access" This stops Gallery looking for them when they are not there. Frustratingly there is no inbuilt way of checking/highlighting this. I have seen that there is a workflow that can be run on the server but shortly after running it all of my server credentials were revoked - possibly a coincidence, but I've gotta be honest - I don't really want to try again. Anyway, I have found that if I can remove access to all users no longer in the AD group, things speed up dramatically. You might also want to remove the users from collections.

RoelEsselink
8 - Asteroid

Thanks for the suggestion Cathey.  We have over a 1000 users there so not really workable. It is really frustrating that even after many years of this performance there has been no improvement.