community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Issue While binding https port with SSL certificate

Highlighted
Meteor

I am trying to enable HTTPS on my private Gallery. I am following the steps mentioned in following URLs:

 

https://community.alteryx.com/t5/Alteryx-Server-Knowledge-Base/Configuring-Alteryx-Server-for-SSL-Ob...

and

https://help.alteryx.com/server/current/admin/Configuration/EnableGallerySSL.htm

 

While binding the https port 443 with certificate I am getting "The Parameter is Incorrect"

Command:

netsh>http add sslcert ipport=0.0.0.0:443 certhash=f5db7e2494981bb3004380e92b4faafb2ddd66d5‎ appid={eea9431a-a3d4-4c9b-9f9a-b83916c11c67}
The parameter is incorrect.

 

Please help with this. Also would appid used in above command will be different for my Gallery. If yes, where can I find it ?

Moderator
Moderator

Hi @pushpraj - a possible cause for this problem is hidden characters being copied from the Certificate Manager page when you copied the thumbprint. If you copy the thumbprint from the details window in Certificates, check for a hidden character at the start (you can check by pasting into a notepad and making sure all whitespace/hidden characters are gone). 

 

Also, the appid you are using is correct :)

Sophia Fraticelli
Customer Support Engineer
Atom

Hi   

 

Can you please tell me if you were able to fix the issue? I'm also facing the same issue. As per the documentation (link below) it doesnt ask to change anything other than ‘certhash’ value. Not sure if the Appid has to be the one used in the documentation or not? Can you please guide me here? If I have to replace the AppiD, then how do I get that?

 

https://help.alteryx.com/server/current/admin/Configuration/EnableGallerySSL.htm?tocpath=Configure%7...

 

Thanks,

Srikanth

 

Atom

i solved it by following the solution given in below article:

 

https://stackoverflow.com/questions/779228/the-parameter-is-incorrect-error-using-netsh-http-add-ssl...

 

  1. Copy the command into notepad
  2. Save it as ANSI
  3. Close and reopen the file
  4. Remove bogus ? characters
  5. Copy from notepad to the command prompt and run the command

Cheers,

Srikanth