We are updating the requirements for Community registration. As of 7/21/21 all users will be required to register a phone number with their My Alteryx accounts. If you have already registered, you will be prompted on your next login to add your phone number.

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Chain app not updating correctly

adrilarotta
8 - Asteroid

So I have this issue with chain apps, I have asked to Alteryx Consultants and they have not been able to solve it and I can't believe this does not have a solution.

 

The first app takes the inputs, and as a result two alteryx data bases are obtained, one feeds a dropdown list tool where the user can select the city/municipality for which the income tax will be calculated and the other output is the input for the second app which contains the actuall data with the value of the tax. I am doing tests with two different sets of data (both of them with the same schema).

 

When the workflow is run with the first set of data (the same uploaded in designer as input) it works fine, but then when I upload the second set of data it works just for the first municipality I select, if I re-run and select a different municipality or even the same one I selected at first, the result obtained correspond to the first set of data not the second.

 

If I change the data in designer to the second set of data it will occur the same, the workflow will run without any problem for the second set and if I select the first set I will obtain correctly just the result for one municipality and the others will correspond to the second set of data.

 

One particularity is that the dropdown list update correctly, the problem is with the input file for the second application apparently. In designer it works perfectly, also I already have gone through the change of the paths to relatives...

 

I appreciate your help to check once more and identify where the inconsistency is.

8 REPLIES 8
AkimasaKajitani
14 - Magnetar

Hi @adrilarotta 

 

Do you run the chained app on server?

And did you contain the 2nd app of input file at upload the server?

 

When you upload the chained app, you have to contain the input file of second app.

It is temporary file, but the Server need it to understand the file path of 2nd app input file.

danilang
18 - Pollux
18 - Pollux

Hi @adrilarotta 

 

There are many possible reasons why this may not work.  It could be as simple as an Action tool not being configured correctly, it could be a logic error in a filter, or any number of other issues.  Can you share your workflow?  If not your actual workflow then a stripped down version with just enough tolls and a limited data set to show the problem?  At the very least, can you post images of the configs of all the Interface, Action tools and the tools that they are connected to?  

 

Dan

adrilarotta
8 - Asteroid

Hi @AkimasaKajitani and @danilang,

 

Thanks for your interest in helping me, for real not even the Alteryx consultant have been able to solve this issue, I attach the two apps and the inputs for the apps, I am uploading the App_1 with the exact same configuration you found in the files. Regarding to the workflow assets, I have tried uploading just the second app, and then the second app and the two outputs (dropdown list and the input) and nothing have worked.

 

Please keep in mind that it works perfectly in designer, the problem I am having is when I uploaded it in the Gallery (when I re-run to select another municipality or even the same). If you have the chance to upload it to the Gallery please try running the application with the second Dataset, and selecting one municipality, then re-run and select the same municipality, you will see the error.

 

I do appreciate your help.

adrilarotta
8 - Asteroid

And these are the input files...

AkimasaKajitani
14 - Magnetar

It seems to work well at my test of running on Gallery.

The output was made by Dropdown item that the Sample File 2 have only.

 

AkimasaKajitani_1-1621399289609.png

 

 

I think that is the problem of uploading process to Gallery.

At uploading to the Gallery, you have to contain the output files of App1.

 

AkimasaKajitani_2-1621399504789.png

 

Could you check it?

adrilarotta
8 - Asteroid

Hi @AkimasaKajitani

 

I am uploading the application in the same way you show in the screenshot and still don't work, it works ok in the first run but when I re-run for the same municipality the result change and the value shown is from the first dataset not the second one. It's like it shows only one correct result, the others correspond to the data preloaded in designer (dataset1 in this case), I really have tried all the possible combinations and the error persists, I don't know if it is due to the version, I'm Working with 2020.3... Which version are you using?

AkimasaKajitani
14 - Magnetar

I tried to run on the Server and Designer again by same filter and two files.

So I got the same result on them.

It seems that your workflow is no problem.

 

My running environment is as following.

  • Server: 2021.2.1.35394

 

But I can't find this problem on release notes of Server.

 

adrilarotta
8 - Asteroid

Thanks a lot for your help, I'm gonna keep on checking with Alteryx support if there is a problem of the version.