Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
Andy Uttley, Alteryx ACE, makes music with Alteryx | Math + Music

CANCELLED: Publish to Tableau Macro stopped working

7 - Meteor

Hello -


I've been using the Publish to Tableau Server macro for months with no issues (1.04).  I've already upgraded to Alteryx 11.0 and the publishing has been working fine... until this morning.  I did change my enterprise password last week so I thought it had to do with passwords.  However, I was able to publish after I changed it then.


System:  Alteryx, 64-bit

Tableau Server:  supports Tableau 9.2


So far, here are the actions I've taken:


1) ensured that my password did not contain ANY special characters

2) my current password is 15 chars long so I tried using an 8-char password

3) I've downloaded the latest version of the tool (1.08)

4) Checked with our IT server support and nothing has changed since last week - am able to go to the Tableau Server directly and publish workbooks from Tableau Desktop using the same credentials as used in the Publish to Tableau tool.


Error message:

Error: Publish to Tableau Server (9): TableauServer.Login: Tool #4: Tableau Server API Request (Sign-in) Error Code 401001: Signin Error -- Error signing in to Tableau Server


Any suggestions?

7 - Meteor

Turns out that the initial time that the publish failed was from an unknown reason. However, I took it to mean that I had changed my enterprise password the weekend before and that was the reason for Monday's fail.  So, I subsequently changed the password to the server (in the tool) to reflect the new password but that still failed.  What I FORGOT was that our Tableau Server was integrated with our Enterprise Security; instead it uses SAML and we just use a generic password to get in.  I muddled 2 different issues together.  Works now with the generic password, while the original fail is still unknown but I'll chuck that up to the occasional system quirk (for now, anyway).

Alteryx Partner

So are you saying you don't know what triggered this issue or not? I'm having the same issue and not sure if I understand how you resolved the matter. We use the same password to login in on all systems.

Alteryx Certified Partner

Hi @mscuaycong 


When you refer to to a generic password what type of user did you create on Tableau server? Is your Tableau Server online or On premise?

I'm having the same issue with SAML SSO.

Thanks in advance.