community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
SOLVED

Alteryx Service is unstable

Asteroid

Hello Community,

 

i have installed one full node of Alteryx server. I created a DNS and Virtual ip accessible via F5 in order to access the gallery (Please see attachment Alteryx1)

After doing that Alteryx server goes down. When I try to start it it never happen, then it will started and stopped without a reason so it is very unstable. (Alteryx2)

 

D:\Program Files\Alteryx\bin>alteryxservice stop
AlteryxService Stopped

D:\Program Files\Alteryx\bin>alteryxservice start
Service failed to start: Win32 Error: An instance of the service is already running. (1056)

D:\Program Files\Alteryx\bin>alteryxservice start
Service failed to start: Win32 Error: An instance of the service is already running. (1056)

D:\Program Files\Alteryx\bin>AlteryxService test
AlteryxService version: 2018.4.4.54346 PID: 3080 main thread: 5460
Requested log path exists <D:\ProgramData\Alteryx\Service\AlteryxServiceLog.log> using <D:\ProgramData\Alteryx\Service\AlteryxServiceLog_1.log>.
Local logging enabled level <7> path <D:\ProgramData\Alteryx\Service\AlteryxServiceLog_1.log>.
Starting Logging service...
There was an error starting the Alteryx Service:
Failed to register Service URL (183).
Please contact your Systems Administrator to ensure that port 80 is unused and open for inbound connections,
and verify that the Alteryx Service is not already running on this system.

D:\Program Files\Alteryx\bin>alteryxservice start
The Service is not starting in a timely manner.

 

Any idea please?

How can I open an incident to the support team?

 

Many thanks

Asma

 

 

Highlighted
Alteryx
Alteryx

Hi Asma,

 

 

In your URL you are using HTTPS so should look to check "Enable SSL" rather than just adding the s to the Base Address.

 

This will make it use port 443 rather than 80.

 

Let me know how that goes.

 

Asteroid

Hello

Thanks  for your answer

I did not use certificate SSL

I am using the URL via F5 , so F5 is running on HTTPS So even for this I should check Enable SL too?

 

Thanks

Asma

Asteroid

I have checked the Enable SSL but I have still this message

 

D:\Program Files\Alteryx\bin>AlteryxService test
AlteryxService version: 2018.4.4.54346 PID: 2872 main thread: 416
Requested log path exists <D:\ProgramData\Alteryx\Service\AlteryxServiceLog.log> using <D:\ProgramData\Alteryx\Service\AlteryxServiceLog_1.log>.
Local logging enabled level <7> path <D:\ProgramData\Alteryx\Service\AlteryxServiceLog_1.log>.
Starting Logging service...
There was an error starting the Alteryx Service:
Failed to register Service URL (183).
Please contact your Systems Administrator to ensure that port 80 is unused and open for inbound connections,
 and verify that the Alteryx Service is not already running on this system.

 

Thnx

Asma

Asteroid

to register Service URL (183). Please contact your Systems Administrator to ensure that port 80 is unused and open for inbound connections,  and verify that the Alteryx Service is not already running on this system."
2018-12-14 15:40:05.685000,ERROR,5460,AlteryxService,Main,,alteryxservice,,,,,"AlteryxService_SvcReportEvent: App <AlteryxService> message <Failed to register Service URL (183). Please contact your Systems Administrator to ensure that port 80 is unused and open for inbound connections,  and verify that the Alteryx Service is not already running on this system.>"
2018-12-14 15:40:05.687000,ERROR,5460,AlteryxService,Main,,alteryxservice,,,,,"AlteryxService_LogStartupError: There was an error starting the Alteryx Service <Failed to register Service URL (183). Please contact your Systems Administrator to ensure that port 80 is unused and open for inbound connections,  and verify that the Alteryx Service is not already running on this system.>"
2018-12-14 16:10:25.017000,ALERT,6444,AlteryxService,Main,,alteryxservice,,,,,"AlteryxService starting version <2018.4.4.54346> PID <808> Main thread <6444> Command <AlteryxService test>"

Alteryx
Alteryx

Is there definitely not anything else running on port 80?

Asteroid

D:\Program Files\Alteryx\bin>netstat -aon | findstr :80

D:\Program Files\Alteryx\bin>alteryxservice start
The Service is not starting in a timely manner.

D:\Program Files\Alteryx\bin>netstat -aon | findstr :80
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4
  TCP    alteryxserverip:52154    alteryxserverip:80       SYN_SENT        992
  TCP    alteryxserverip:52158    alteryxserverip:80       SYN_SENT        992
  TCP    127.0.0.1:80           127.0.0.1:52127        TIME_WAIT       0
  TCP    127.0.0.1:80           127.0.0.1:52149        TIME_WAIT       0
  TCP    127.0.0.1:80           127.0.0.1:52150        TIME_WAIT       0
  TCP    127.0.0.1:80           127.0.0.1:52155        ESTABLISHED     4
  TCP    127.0.0.1:80           127.0.0.1:52156        ESTABLISHED     4
  TCP    127.0.0.1:80           127.0.0.1:52157        ESTABLISHED     4
  TCP    127.0.0.1:52155        127.0.0.1:80           ESTABLISHED     7160
  TCP    127.0.0.1:52156        127.0.0.1:80           ESTABLISHED     2932
  TCP    127.0.0.1:52157        127.0.0.1:80           ESTABLISHED     992
  TCP    [::]:80                [::]:0                 LISTENING       4

how did you resolve this? any updates further? because I'm also facing the same issue. Thanks.

Alteryx
Alteryx

Hello @asma_rez , what is happening is that you are terminating SSL at F5.

 

When you log in an oauth signature is created from the URL you are using. If you use https, and then are routed to port 80 on Gallery, the oauth signature will not match, since the oauth signature was created using https, and the Gallery is expecting an oauth signature created with http.

 

So, it is important when using SSL, to terminate SSL at the Gallery and port 443, not somewhere before.

Regards,
Stephen Ruhl
Customer Support Engineer