Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Alteryx Server Usage Report

Alteryx Certified Partner

Hey community,


I'm getting the following error when trying the run the usage report via the gallery:


Alteryx Server Report.PNG


I've double checked the port and the user password but still keep getting the error.


Unfortunately I can't rdp into the server to run it from there.



Part time Tableau, Part Time Alteryx. Full Time Awesome

Data Lover

Inactive User
Not applicable

It is saying localhost, try using the IPV4 address with the port instead since you are not RDP into the Windows Server.

Alteryx Certified Partner
Alteryx Certified Partner
I schedule the job to run on the server. 8:00 am Eastern I can look at this with you. Also: are you using the 1st password and not the admin password.
Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Alteryx Certified Partner

I'm sure the guide said to use the user password?

Alteryx Partner

I got same error.

Im using RDP connection and tried all possible host / username / pw combination.

Unable to resolve this.

One thing to note that our windows was installed on C: while alteryx on D: will that make any behavior change?




A few things to add to this post, I experienced trouble shooting the same error:

Server IP Configuration Settings are different on my VM (Server) vs. my Local PC where I cannot run the Server Usage Report.  VM = IPv4 Address, PC = IPv6 Address

Save and schedule from the C drive, D drive will throw the error.

Last, make sure the supported macro .yxmc files are also saved on the VM C drive.

I've got the "Mongo Error" ... "Authentication failed" when running this too.


I moved the workflow/macro from D: drive to C: drive with no success.


I tried with both user and Admin passwords.


The failures are all occurring on the MongoDB Input tool in the macro. I tried hard-coding the credentials into the macro as well.


@MarqueeCrew  -- Any other ideas I'm not thinking of?





Alteryx Certified Partner
Alteryx Certified Partner

When I've used the job, I first run it on the server to get it configured correctly.  Then I schedule it to run on the server and output the data to a network disk.  I prefer to break the job up into the MongoDB dump and then to have a second job which does the calculations and exports.  The data can be read and potentially used to create new value (e.g. telemetry data) without the need to have access to Mongo.


If the "authentication" doesn't work when you're logged into the server, that is clearly 1 issue.  If you can't schedule the job (running on a different server), then you need to force the job to the server.





Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.

@MarqueeCrew   I am currently trying to run it on Designer directly on the Server first. And, that's where the error comes out. I haven't ventured off of the Server and into the Gallery yet. :-)


Other ideas?





Hi Heather, Where you able to find a solution to this issue? I am having the same error. Thanks, Gabriella