Issue
You have installed the Salesforce Output tool package downloaded from the Alteryx Gallery, but the tool does not appear in the tool palette.
Environment
- Alteryx Designer
- Salesforce Output Tool
Cause
- Multiple versions of the Salesforce Output tool may be installed, including a previously deprecated version and causes the tool to not appear correctly unless the optionShow Deprecated Tools is turned on in Alteryx Designer.
Solution A
- Right-click the Tool Palette.
- SelectShow Deprecated Tools
Note:This setting willreset when Alteryx Designer is closed and re-opened. You will need to repeat these steps to see the Salesforce Output tool in the tool palette on each launch.
- If a dialog appears, clickOK on the notice dialog
- Confirm the Salesforce Output tool now appears in the tool palette
Solution B
- Close Alteryx Designer
- Browse to each of the following folders with a Windows file browser:
- %appdata%\Alteryx\Tools
- %programdata%\Alteryx\Tools
- Withinthe above two folders, determine if there are two separate folders for Salesforce Output tools as per the following example:
- Salesforce Output
- SalesforceOutput_v1.3.0
- Note: Removing this folder may cause missing macro errors in workflows setup prior to installing the updated macro. If there are any concerns about removing the folder, consider using Solution A above as a workaround or back up the folder prior to removing it.
- If two separate folders exist such as in the above example, remove theSalesforce Output folder
- Open Alteryx Designer and verify the Salesforce Output tool now appears in the tool palette.