Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Salesforce Output Tool Missing After Installation

DanielF
Alteryx
Alteryx
Created

Issue

You have installed the Salesforce Output tool package downloaded from the Alteryx Gallery, but the tool does not appear in the tool palette.

Environment

  • Alteryx Designer
    • Version 10.5+
  • Salesforce Output Tool
    • Version 1.3

Cause

  • Multiple versions of the Salesforce Output tool may be installed, including a previously deprecated version and causes the tool to not appear correctly unless the optionShow Deprecated Tools is turned on in Alteryx Designer.

Solution A

  1. Right-click the Tool Palette.
  2. SelectShow Deprecated Tools
    Note:This setting willreset when Alteryx Designer is closed and re-opened. You will need to repeat these steps to see the Salesforce Output tool in the tool palette on each launch.

    2019-01-11_14-50-38.png
  3. If a dialog appears, clickOK on the notice dialog

    2019-01-11_14-53-22.png

  4. Confirm the Salesforce Output tool now appears in the tool palette

Solution B

  1. Close Alteryx Designer
  2. Browse to each of the following folders with a Windows file browser:
    1. %appdata%\Alteryx\Tools
    2. %programdata%\Alteryx\Tools
  3. Withinthe above two folders, determine if there are two separate folders for Salesforce Output tools as per the following example:
    1. Salesforce Output
    2. SalesforceOutput_v1.3.0

      2019-01-11_15-16-44.png
  4. Note: Removing this folder may cause missing macro errors in workflows setup prior to installing the updated macro. If there are any concerns about removing the folder, consider using Solution A above as a workaround or back up the folder prior to removing it.
    1. If two separate folders exist such as in the above example, remove theSalesforce Output folder
  5. Open Alteryx Designer and verify the Salesforce Output tool now appears in the tool palette.