community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx Knowledge Base

Definitive answers from Designer experts.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Error: "system.data.oracle client requires 8.1.7 or greater"

Alteryx
Alteryx
Created on

Error: "system.data.oracle client requires 8.1.7 or greater"

 

Please bear in mind this error is not related to Alteryx but to Oracle. This error message is returned from the Oracle Database, therefore please check with your DBA about the configuration and set up of your machine and server before reaching out to support@alteryx.com. However, we are always happy to help so here are a few troubleshooting tips!

 

Which database connection did you use?

If you tried using the ODBC connection, try using the OCI (New Oracle Connection).  If you do not know what the TNS server name it can be found in the TNSnames.ORA file. Your DBA will also know this. 

 

What permissions do you have?

Go to the Oracle Client folder.

2- Right Click on the folder.

3- On security Tab, Add “Authenticated Users” and give this account Read & Execute permission.

4- Apply this security for all folders, Subfolders and Files (IMPORTANT).

5- Don’t Forget to REBOOT your Machine; if you forgot to do this you will still face the same problem unless you restart your machine.

 *Before changing any permission settings please check with your IT

 

How many instances of Oracle do you have installed?

Oracle may find it difficult to navigate and select the correct version if it has more than one version installed. If you only need one of them it is better just to remove them all and reinstall the one that is needed.

 

Do you have the correct drivers installed?

One way to check to see if you have the right drivers installed is to set up the DSN connection through Alteryx, navigate to the ODBC admin and see if any drivers populate for either the 32 or 64 bit connections.

 

Do you have one of the supported client versions?

Please see the Technical Specifications

 

Please bear in mind often this error is not related to Alteryx but to Oracle. This error message is returned from the Oracle Datbase side and therefore please check with your DBA about the configuration and set up of your client before reaching out to Alteryx Support

 

Best,

 

Jordan Barker

Client Service Support Engineer

Comments

Copy and paste the Oracle instant client drive in under the folder "oracle_odbc" in the following directory: 

C:\oracle_odbc

 

Check the content of the folder and make sure the oci.dll file is in the directory.  It resolved my issue with these two errors:

 

unable to find the oci.dll

 

 OracleClient requires Oracle client software version 8.1.7 or greater