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32-bit Database Connection - "The system cannot find the file specified"

Moderator
Moderator
Created on

Issue

 

When attempting to use a 32-bit database connection in the Input Data or Dynamic Input Tool, the following error is received:

 

The system cannot find the file specified

 

2018-12-17_17-38-37.png

 

 

Environment

 

  • Alteryx Designer
  • 32-bit Database Connection (ODBC, OCI, OLEDB)
  • Windows Operating System

 

 

Cause

 

AlteryxConnect32.exe is missing or inaccessible from the "{Alteryx Installation Folder}\bin\bin32\" folder

 

Solution A

 

  1. Re-install Alteryx Designer. This should replace the missing file.
  2. Attempt to connect to the 32-bit database connection again. If the error does not resolve, continue to Solution B.

 

Solution B

 

  1. Browse to the "{Alteryx Installation Folder}\bin\bin32\" folder. On a default admin installation, this is "C:\Program Files\Alteryx\bin\bin32".
    1. If you are unsure of the location, right-click the Alteryx Designer icon on the desktop or from the Windows Start Menu.
    2. Click Properties.

      2018-12-17_18-15-12.png

    3. The location of the "bin" folder is listed in the "Target" field.

      2018-12-17_18-21-03.png

  2. Determine if AlteryxConnect32.exe appears in the listing of files. (Note: If file extensions are turned off, the file may simply be named AlteryxConnect32.)

    2018-12-17_17-54-20.png


  3. If the file exists:
    1. Determine with your Information Technology (IT) or Security team if an antivirus or security product may be blocking the execution. An exception in the antivirus or security product may need to be added to allow the application to execute properly.
  4. If the file does not exist:
    1. Determine with your IT or Security team if an antivirus or security product may be quarantining and/or deleting the AlteryxConnect32.exe from the above directory. An exception in the antivirus or security product may need to be added to allow the application to remain in the proper location on the system.
    2. Once an exception is granted, the file may be able to be restored from the antivirus or security product's quarantine.
    3. If the file is unable to be restored, re-install Alteryx Designer to replace the AlteryxConnect32.exe file.