Alteryx IO Discussions

Customize and extend the power of Alteryx with SDKs, APIs, custom tools, and more.

Internal Error - Deadlock detected (@1)

9 - Comet

What is the cause of this error?


Internal error: Failed to read port assignment
Internal Error - Deadlock detected (@1)




This error seemingly cropped up today with no changes to my custom tool, and nothing I've tried has gotten rid of it.

  • Designer 2023.1.1.247
  • Python v3.8.10
  • ayx_plugin_cli v1.1.0
  • ayx_python_sdk v2.2.0


This is currently affecting all of my custom tools, including one that does nothing but pass data through


class MyPlugin(PluginV2):
    def __init__(self, provider: AMPProviderV2): = "My Plugin"
        self.provider = provider

    def on_record_batch(self, batch: pa.Table, anchor: Anchor) -> None:
        self.provider.write_to_anchor("Output", batch)

    def on_incoming_connection_complete(self, anchor: Anchor) -> None:

    def on_complete(self) -> None:



I'm building the tool with


rd /s /q "ui\PlaceholderToolName" & echo y | ayx_plugin_cli designer-install --use-ui --install-type user



I've tried

  • Deleting .ayx_cli.cache, build, ui\PlaceholderToolName, and main.pyx
  • Deleting C:\Users\username\.shiv
  • Deleting %APPDATA%\Alteryx\Tools\toolname and C:\ProgramData\Alteryx\Tools\toolname
  • Installing as both user and admin
  • Creating a brand new tool with `ayx_plugin_cli create-ayx-plugin --use-ui` and copying over the code
  • Restarting Designer and my computer
  • Uninstalling all version of Python, deleting AppData\Local\Programs, reinstalling Python 3.8.10 and ayx-plugin-cli and ayx-python-sdk

@craigbloodworth  Check your requirements-local.txt - it should have a dot in it, to install the tool backend - in the form of the ayx_plugins python package - into the YXI


In general, the error happens when there's an issue starting/connecting to the tool. This can happen for a variety of reasons, including but not limited to firewall settings or syntax/"compile-time" errors in the tool code. I'm not sure why there would be MORE occurrences of the issue in 2.3.0, though - that's the first version that doesn't rely on a shiv artifact, the first-run/unpacking of which has been the main point-of-failure in the past, and the main source of the error when it's sporadic

8 - Asteroid

For us, this was caused by a Permissions Issue.


Here's how we fixed it (both on server and designer):

1.  Go to C:\Program Data\Alteryx

2.  Set the folder permissions of the SPECIFIC ACCOUNT that is using it to FULL CONTROL


That's it!



  • On the server: 
    • Set the Permissions to FULL CONTROL for the service account that uses Alteryx. 
    • Note that this needs to be set for the INDIVIDUAL account, even if the service account is a part of a group.
  • On the DESIGNER version:
    • Make sure the account of the user of that machine has FULL CONTROL of that folder at the INDIVIDUAL level, even if that user has full control at the group level.



  • Our assumption is that this was caused by the fact that Alteryx needed FULL CONTROL permission at the account level to access Alteryx in the Program File.
5 - Atom

1.  Go to C:\Program Data\Alteryx

2.  Set the folder permissions of the SPECIFIC ACCOUNT that is using it to FULL CONTROL

This resolved it for me as well.



Can you please try this solution?


(1) Navigate to the .shiv folder for c:\users\USER_NAME\.shiv
(2) Back-up the folder, then delete the .shiv folder.

(3) Delete the Connector folder. This is in one of the following folders

  • %ProgramData%\Alteryx\Tools
  • %appdata%\Alteryx\Tools

(4) Download a compatible version of the tool from Alteryx Market Place and install it (right-click and run the installer as Administrator if installing on the Server).

(5) Restart the Designer or your Server.



Chandra Shekar Balusugure