Alteryx Designer

Find answers, ask questions, and share expertise about Alteryx Designer.

There is no Question corresponding to the specified App/Macro value "5374228".

Highlighted
6 - Meteoroid

I have a stream which takes sales data and for each product sold iterates through a batch macro and creates a decision tree. This stream was working up until recently, but now I receive the following error:

 

"There is no Question corresponding to the specified App/macro value '5374228'." 

 

Where 5374228 is one of our product IDs. I have searched around but cannot find any information about what may be causing this error. I found this thread (https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Warning-There-is-no-Question-correspon...) which suggests that the data types were not lining up between the macro input and the macro itself - but I have verified that this particular field is cast as an int in both places (also tried a string but got the same error).

 

Any ideas??

Highlighted
11 - Bolide

Could you share the workflow in which you are using the batch macro. If you send an exported workflow it will send the batch macro and any input files along with it. You can do this by going to Options -> Export Workflow.

Highlighted
6 - Meteoroid

Unfortunately I cannot post the workflow file since it contains sensitive sales/customer information. Here are screenshots of the stream macro:

 

MACRO:

 

Select node: ensures data is typed as int

Formula 1: Buckets numerical fields to text strings (i.e. 2.5 becomes "Bucket 1-5")

Formula 2: Adds a field that indicates whether a sale was made or not (for that particular customer/product combination) to balance the data for modeling

Oversample: Ensure the data is ~50/50 split between customers who ended up buying the product and those who didnt

Sample node: split into test and evaluation nodes. Was used during model selection phase.

Output: write the model weights to a yxdb for scoring in a separate stream.

Control parameter: loops through each product in the dataset

Action tool: updates the model name to the product ID to write to the suffix of the yxdb

 

MacroMacro

 

 

MAIN STREAM:

 

Input: Select data from my SQL server which has pre-cleansed data for input into the model

Summarize/filter/join: Ensure there are enough categories for each product to feed into the decision tree

Autofield: typing data

Select: ensuring product field is typed as an INT

Summarize/select: get a list of all products to feed into the action tool in the macro

Formula: add in a timestamp to track when the process ran for tracking purposes

Select: ensure product field is typed as an INT

 

 

StreamStream

Highlighted
Alteryx Partner

This should be a relatively easy fix. This warning comes about when you haven't set the "Name" value in the Annotation section of the Interface tool. As long as that matches what the variable value is the error should go away. NameAnnotation.png

Let me know if this doesn't solve your issue :) 

Highlighted
8 - Asteroid

Hi,

Your solution has saved my life today. I am trying to trigger a workflow by using Alteryx API by passing the text box value. Based on the text box value I am building the dynamic file path and processing the file. With out this setting I am getting error that the file path not exists, but for the text box control it is throwing only warning. I am always concentrating on input tool instead of the text box. After changing the name in annotation my API is working with out any issues. But the unknown part is that, if I run the workflow from the Gallery, then it is working with out this setting.

Again thank you for this solution. 

Labels