Alteryx Designer

Find answers, ask questions, and share expertise about Alteryx Designer.

Publish To Tableau Server Tool problems

Highlighted
5 - Atom

Hello -

 

Just downloaded this tool and have been trying to get it to work.  Having 2 issues with it:

 

1. We work on VM's, on 1 VM when I select "refresh project name list" and run it, it populates with the list of project names fine.  On another VM, when I do the same exact thing, it does not populate the drop down at all.  They are both running same/newest verison of Alteryx.

 

2. On the VM that is working, I was able to publish the TDE fine the first time, no problems.  However, when I now select "Overwrite source" in the output options and run again after making some changes to my workflow, I get the folliowing error:

 

    Publish to Tableau Server (7)    Tool #592: Record #1: Tool #99: Cannot access file: D:\Temp\Engine\Engine_5664_657a04bb30cf496c873431dd5b2b723b_\Lead_Routing_Test.tde

 

Any idea what might be causing this?  I have ensured the D: drive is shared so don't think its a permissions issue w/ the server trying to read from the drive, but not 100% sure.  Any help is appreciated since this will be a very helpful tool if we can get it to work.  Thanks!

 

 

Highlighted
7 - Meteor

Hi Jeremey,

 

If you have "refresh project name list" checked your data will not publish to server. I wonder what happens if you uncheck that and run the workflow again.

Highlighted
8 - Asteroid

Hey, Jeremy.

 

Any update on this?  Were you able to get it to work ok?

Highlighted
5 - Atom

I experienced the very same error.  After beating my head on a rock, I decided to try a less "root cause analsys" process.

 

I used [Ctrl]+A to select the entire contents, copied everything, then pasted it all into a new module.

 

The new module ran without issue.  Client is happy, boss is confused, and I am able to move on to the next fire.

 

--Good Luck

 

"Information is not knowledge." - Albert Einstein

Highlighted
Alteryx Certified Partner

Copying it into a new blank workflow did the job for me too, cheers!

Highlighted
6 - Meteoroid

Make sure you haven't "disabled all tools that write output" in the workflow configuration -> Runtime. 

Highlighted
6 - Meteoroid

My eyes just rolled into the back of my head. How is this ok from a software standpoint?

Labels