Alteryx Designer

Find answers, ask questions, and share expertise about Alteryx Designer.

Microsoft Access connection problems

Highlighted
Alteryx Certified Partner

Hi Alteryx Community,

 

We are currently having problems connecting to an 2010 access database sitting on a shared drive. This is the error message that appears after selecting the file location for a file ending with .accdb

We also get the same error when saving the database locally.

 

Alteryx Error.jpg

 

There are only a few tables in the database, one which we are trying to retrieve contains 500K rows and the other 3K.

Has anyone seen this before? Have you got a workaround?

 

Dowloading and installing the ODBC driver is not a possible option - has been tried and failed.

 

Thanks,

Alexandra

Highlighted
Alteryx Alumni (Retired)

Hi Alexandra!

 

I think this error is the result of the driver not recognizing the feild types of your dataset properly. I would create a "dummy" row of data that has no nulls, and a representative data entry for each field. Likewise, if you are outputting to Access .accdb, make sure the first row doesn't contain any null entries.

 

Let me know if this helps!

 

Alex Koszycki
Program Manager, Community Platform
Highlighted
Alteryx Partner

Hello Alexandra,

 

Hope you are doing good.

Wanted to know if you were you able to solve this issue, if yes then how ?

 

Highlighted
Alteryx Certified Partner

Hi Suruchi,

Thank you for the message. I am well, and you?

 

So the process I took was to check the drivers were up to date, dowloading the lastest ones:

https://help.alteryx.com/9.5/DatabaseSupport.htm and it turns out I was also using an older version of the accesss database from which the data was being created, so again I renew this. Finally I connected to ACCDB in the input tool and solved!

 

 

Are you facing similar issues?

Labels