Alteryx Designer

Find answers, ask questions, and share expertise about Alteryx Designer.

Date Interface Tool

Highlighted
7 - Meteor

Hi, I'm new to Alteryx. I have a difficulties on this. I have similar problem but the error says no table chosen. But I already select the table. I attached the screenshot below.

Highlighted
8 - Asteroid

@Nurul_1994

 

I viewed your pdf and there is not really enough information there for me to try to help you.  The one things which comes to mind is, if you are trying to use the Calendar tool to select a range of dates, does your data have a date field?  Is it formatted correctly for Alteryx?  

 

I would check that.  Or you can put together a workflow with dummy data and I can then look at what you are trying to do.

Highlighted
7 - Meteor

Hi this is my workflow. As you can see i already have the filter.

Highlighted
7 - Meteor

And i cannot find the date filter tool.

Highlighted
7 - Meteor

Hi, I managed to find the date filter. This is my updated workflow.

Highlighted
7 - Meteor

When i run as analytic app the error message will pop out says that tool #2 no valid fields were selected. But i selected the date. 

Highlighted
7 - Meteor

What I'm trying to do is I want the system to prompt the user then the user will enter the start and end date then the data will show according to the dates selected.

Highlighted
8 - Asteroid

Are your Date Fields formatted as actual dates which Alteryx recognizes?  Dates in Alteryx is YYYY-MM-DD.  Make sure you are following the correct date format in Alteryx.

Highlighted
7 - Meteor

Hi this is my actual date data. Do i still need to format it?

Highlighted
8 - Asteroid

These are correct format for Alteryx.  The Calendar tool does not use the time portion, that I am aware of.  Can you try, creating new date fields, with just the YYYY-MM-DD portion of the date?  Then try to use it. 

 

Also, I can not tell from the image, if your dates are figured correctly.  In the Select Tool, what is the formatting for the dates?  Just make sure that they are in a Date format when you create the new fields.  Then try again on the new fields you created. 

 

If that does not work, then perhaps a dummy workflow attached would be helpful when trying to see your configuration.  Thanks.

Labels