Alteryx Designer

Find answers, ask questions, and share expertise about Alteryx Designer.
Register for the upcoming Live Community Q&A Session - and don't forget to submit your questions for @DeanS regarding the future role of analytics here.
SOLVED

Alteryx Engine: Unable to create log file

Highlighted
7 - Meteor

I've created a workflow that runs macro1. Macro1 runs macro2, and macro2 runs macro3, etc. However, when macro2 tries to run macro3, alteryx throws the following error: "Alteryx Engine: Unable to create log file"

 

Is this a known issue? What is the solution for it?

 

Thanks in advance.

Highlighted
12 - Quasar

Hi Jo

 

from the message i see the logging directory pointing to a UNC path

Alteryx Engine: Unable to create log file "\\londata002.uk.net.intra\CMPPBI\Alteryx Log Files\Current\Alteryx_Log_1452675344_1.log

is that correct ?

 

i suspect this could be an permission issue , but i think you dont need to provide the UNC path

 

for further troubleshooting, can you provide the screenshot of system settings. refer the below

Alteryx Log.PNG

Highlighted
7 - Meteor

The screenshots show both alteryx configuration menus, from server and designer.

alteryx_server_conf.png

 

alteryx_server_conf_2.png

Highlighted
12 - Quasar

ok.

can you change the Logging Path in User Settings to your Local Path and try (the One starts with \\londata002

 

 

Highlighted
7 - Meteor

Regrettably, it does not solve the issue.

Highlighted
7 - Meteor

The following log files are an example of the issues we have been facing:

 

Macro that succeeded on creating the log file (Alteryx_Log_1453386616_1.log):

 

Started running \\londata002.uk.net.intra\CMPPBI\Environment\CIA SBX\Alteryx\Libraries\ModuleRunner\Configurable_ConditionalRunner.yxmc at Thu Jan 21 14:30:16 2016

00:00:0.022 - ToolId 220: UpdateMonthlySummarySharepoint Not Ran

Finished in 00:00:0.058

 

Macro that failed on creating the same log file (Alteryx_Log_1453386606_1.log):

 

Started running D:\ProgramData\Alteryx\Service\Staging\8088_940f4b722bd6475b84ea2b5fb12b7f61\BatchScheduler.yxmd at Thu Jan 21 14:30:06 2016

00:00:0.311 - Alteryx: Tool #46: Tool #8: Alias translated to odb:Provider=SQLOLEDB.1;Password=__EncPwd1__;Persist Security Info=True;User ID=CIA_admin;Initial Catalog=CIA;Data Source=LONS00114361\FIENTDEV, 51463;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=LONS00110450;Use Encryption for Data=False;Tag with column collation when possible=False|Audit."Configuration"

00:00:1.282 - Alteryx: Tool #46: Tool #8: 2400 records were read from aka:CIA_LOCAL (Audit."Configuration")

00:00:1.294 - Alteryx: Tool #46: Tool #3: 18 records were True and 2382 were False

00:00:1.304 - Alteryx: Tool #10: Tool #108: Text Input (1): 1 record was output

00:00:1.314 - Alteryx: Tool #46: Tool #10: Tool #1: 1 record was output

00:00:1.326 - Alteryx: Tool #46: Tool #11: 3 records were joined with 0 un-joined left records and 15 un-joined right records

00:00:1.339 - ToolId 3: 1 records were True and 0 were False

00:00:10.341 - ToolId 6: Record #1: Tool #12: BatchSchedulerStartBatch Ran Successfully

00:00:10.380 - ToolId 6: Record #1: Tool #12: 1 iterations were run

00:00:10.401 - ToolId 6: 1 iterations were run

00:00:10.440 - Error - ToolId 28: Record #1: Alteryx Engine: Unable to create log file \\londata002.uk.net.intra\CMPPBI\Alteryx Log Files\Current\Alteryx_Log_1453386616_1.log

 

The same log file is written by one workflow and there's a second workflow that tries to write to the same log file and fails.

Highlighted
13 - Pulsar
13 - Pulsar

Have any solutions been found for this?  I just started getting this error today from workflows that have been working fine for months.

Highlighted
Alteryx Alumni (Retired)

Hey everyone,

Thank you for the info and feedback! We are actively taking a look into this issue and expect to have a resolution for an upcoming release. I'll update this thread once we have some more information and release availability.

Highlighted
Alteryx Alumni (Retired)

Hi all - updating this thread - this issue has been resolved and is available in version 10.5. If you haven't already updated, please do so. If you have updated and continue to see any issues regarding logging (or anything at all, really) please let us know. Thank you!

Labels