Alteryx Designer Knowledge Base

Definitive answers from Designer experts.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here
With the release of 2018.3 comes the long-awaited and highly anticipated Python Tool! This article is a general introduction to using the tool.
View full article
While trying to connect to Snowflake from Alteryx Designer, using Input Data tool, the following error is thrown after running the workflow: Error: Input Data (1): Error SQLExecute: No active warehouse selected in the current session. Select an active warehouse with the 'use warehouse' command.
View full article
When starting Alteryx Designer the below error is received: There was an error while loading: Object reference not set to an instance of an object.
View full article
An Unhandled Exception occurred when opening a workflow
View full article
The error message appears when using System Settings in Alteryx Designer.
View full article
Not able to clear the In-DB connection string history. There is no option or button to clear it.
View full article
When your Python libraries don't work the way they should in Python tool, restoring the tool to it's original state could be the solution. This article walks through how to restore Python libraries and the virtual environment associated with the Python tool.
View full article
Alteryx provides product technical support for a period of eighteen (18) months after the Release Date of each Release Version, as outlined in the tables below.   NOTE: You can find product 'Release Version' details for all Alteryx Analytics Platform products by following the steps here.   Alteryx Designer & Server Release Version Detail Release Date End of Support (EOS) 2020.1.1.23790 3/5/2020 9/5/2021 2019.4.8.22007 1/27/2020 7/27/2021 2019.4.6.21113 1/6/2020 7/6/2021 2019.4.4.20206 12/9/2019 6/9/2021 2019.3.2.15763 9/3/2019 3/3/2021 2019.2.7.63499 7/9/2019 1/9/2021 2019.1.4.57073 2/13/2019 8/13/2020 2018.4.3.54046 11/14/2018 5/14/2020 2018.3.5.52487 10/1/2018 4/1/2020 2018.3.4.51585 8/27/2018 2/27/2020 2018.2.6 8/16/2018 2/16/2020 2018.1.6 7/17/2018 1/17/2020 2018.2.5.48994 7/5/2018 1/5/2020 2018.2.4.47804 5/31/2018 12/1/2019 2018.1.4.44311 4/2/2018 10/2/2019 2018.1.3.42973 3/6/2018 9/6/2019 11.8.3.40692 1/19/2018 7/19/2019 11.7.4.37815 11/28/2017 5/28/2019 11.5.1.31573 8/15/2017 2/15/2019 11.3.3.30523 7/14/2017 1/14/2019 11.3.2.29874 6/27/2017 12/27/2018 11.0.5.26351 3/21/2017 9/21/2018 11.0.3.25674 2/15/2017 8/15/2018 10.6.8.17850 7/12/2016 6/28/2018 10.6.6.17413 6/28/2016 12/28/2017 10.5.9.15014 5/5/2016 11/5/2017 10.1.7.12188 2/18/2016 8/18/2017 10.1.7.11834 2/4/2016 8/4/2017 10.1.6.11313 1/14/2016 7/14/2017 10.1.6.60263 11/30/2015 5/30/2017 Predictive Analytics 10/24/2015 4/24/2017 10.0.9.58949 9/26/2015 3/26/2017 10.0.9.58645 9/9/2015 3/9/2017 10.0.9.58529 9/3/2015 3/3/2017   Alteryx Connect Release Version Release Date End of Support (EOS) 2020.1 3/5/2020 9/5/2021 2019.4 12/9/19 6/9/21 2019.3 9/3/2019 3/3/2021 2019.2 6/7/2019 12/7/2020 2019.1 2/13/2019 8/13/2020 2018.4 11/14/2018 5/14/2020 2018.3.0  8/27/2018 2/27/2020 2018.2.4.47804 5/31/2018 12/1/2019 3.0.0_0c4cae69 3/6/2018 9/6/2019 2.0.0_05b4e5c2 11/28/2017 5/28/2019 1.0.1.31573 9/12/2017 3/12/2019 1.0.0.31573 8/15/2017 2/15/2019   Alteryx Promote Release Version Version Information Displayed in Product Release Date End of Support (EOS) 2020.1 2020.1 3/5/2020 9/5/2021 2019.4 2019.4 12/9/2019 6/9/2021 2019.3.0 v2019.3.0 - Build 7daa823 9/3/2019 3/3/2021 2019.2.0 v2019.2.1 - Build cf6851d 6/7/2019 12/7/2020 2019.1.0 v2019.1.0 - Build f8ae666 2/13/19 8/13/2020 2018.4.1 v2018.4.1 - Build 167a0f1 12/4/2018 6/4/2020 2018.4.0 v2018.4.0 - Build 5926960 11/14/2018 5/14/2020 2018.3.1 v2018.3.1 - Build d88f0a6 10/1/2018 4/1/2020 2018.3.4.51585 v2018.3.0 - Build c14dfc7 8/27/2018 2/27/2020 2018.2.4.47804 v2018.2.0 - Build 593b5b29 5/31/2018 12/1/2019 2018.1.3.42973 v2018.1.0 - Build 2bfb396 3/6/2018 9/6/2019   Alteryx Analytics Product Compatibility Policy Alteryx is committed to ensuring that workflows created in legacy versions of Alteryx Designer will continue to work as expected with newer versions of Alteryx Designer. Alteryx will identify any known workflow compatibility issues. With the release of 11.7, a user may convert workflows created in a newer version of Alteryx Designer for use in an older version of Alteryx Designer. In this 'downgrade' scenario, a dialog appears asking the user to confirm or cancel the conversion process. Conversions performed in this manner are not fully tested for compatibility. For Alteryx Designer users who also use Alteryx Server, Alteryx is also committed to ensuring that in an upgrade scenario, legacy versions of Alteryx Designer are able to successfully connect to and use the newest Alteryx Server version. Therefore, it is always recommended to upgrade Alteryx Server first and the Alteryx Designer installations are upgraded thereafter. Alteryx will identify any known upgrade compatibility issues. If you experience any issues with an upgrade, please visit alteryx.com/support.   Alteryx Designer Predictive Tools Compatibility Policy Alteryx Designer users can install predictive tools for use with open source R, or Microsoft R. This table details the versions compatible with each release of Alteryx Designer.   Alteryx Designer Version Standard R Version RRE - Revolution R Enterprise (renamed as Microsoft R Server in 2016) Microsoft R Client (MRC) Microsoft R Server (renamed as Microsoft Machine Learning Server in 2018) Microsoft Machine Learning Server (MMLS) 2020.1 3.5.3 Deprecated by vendor - Not supported 3.5.2 Deprecated by vendor - Not supported 9.4.7 2019.4 3.5.3 Deprecated by vendor - Not supported  3.5.2 Deprecated by vendor - Not supported 9.4.7 2019.3 3.5.3 Deprecated by vendor - Not supported  3.5.2 Deprecated by vendor - Not supported 9.4.7 2019.2 3.5.3 Deprecated by vendor - Not supported 3.5.2 Deprecated by vendor - Not supported 9.4.7 2019.1 3.4.4 Deprecated by vendor - Not supported 3.4.3 Deprecated by vendor - Not supported 9.3 2018.4 3.4.4 Deprecated by vendor - Not supported 3.4.3 Deprecated by vendor - Not supported 9.3 2018.3 3.4.4 Deprecated by vendor - Not supported 3.4.3 Deprecated by vendor - Not supported 9.3 2018.2 3.4.4 Deprecated by vendor - Not supported 3.4.3 Deprecated by vendor - Not supported 9.3 2018.1 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 11.8 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 11.7 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 11.5 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 11.3 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 11.0 3.3.2 Deprecated by vendor - Not supported 3.3.2 9.0/ 9.1 NA 10.6 3.2.3 8.0 Not supported NA NA     Alteryx Analytics Platform Hardware and Operating System Requirements Product Chip Disk Size Machine OS Processor RAM Designer Quad core (single chip) 500GB - 1TB Minimum: 64-bit, High Performance: 64-bit, 32-bit not supported Microsoft Windows 7 or later (64-bit) 2.5GHz or faster 8GB 16GB Connect Quad core (single chip) 100GB Recommended: 64-bit, 32-bit not supported Microsoft Windows Server 2008R2 or later 2.5GHz or faster 8GB Promote Quad core (single chip) 100GB Required: 64-bit, 32-bit not supported Linux CentOS 7 2.5GHz or faster 16 GB Server Quad core (single chip) 1TB Recommended: 64-bit, 32-bit not supported Microsoft Windows Server 2008R2 or later 2.5GHz or faster 16GB 32GB   Supported Browsers for Alteryx Analytics Platform   Alteryx Analytics is supported on the following versions of Chrome, Safari, Firefox, Internet Explorer and Edge web-browsers*:       Chrome - Windows Safari - MacOS Firefox Standard Release Internet Explorer Edge Alteryx Analytics Platform latest 11 and above latest (68 and above for Firefox ESR) 11 and above latest         *Note: from time to time, the vendor may provide an update to its web-browser that results in compatibility issues with the browser version used by Alteryx in the development and pre-release testing of the Alteryx platform. Alteryx will use reasonable efforts to mitigate against this risk but we also encourage you to be mindful of browser versions used within your organization and to manage your deployment of the Alteryx platform accordingly.   Alteryx Virtual Environment Support Nutanix, Azure, AWS, VMWare, GCP. All of Alteryx's products run in modern virtualized environments that are properly configured. Support also depends on using a supported and properly configured Windows operating system that also meets or exceeds minimum OS hardware environments. Alteryx Server MongoDB Support Policy Alteryx Server users have two options for managing user and instance metadata. 1) Use the version of MongoDB embedded in the server installation 2) BYO (Bring Your Own) Mongo DB instance Alteryx ships a version of MongoDB in product <OR> customers can connect to their own version. In the case of the latter, Alteryx doesn't provide support, but we do ensure that users are able to successfully connect to their own existing instance of MongoDB and the expectation is that users will be able to connect to that MongoDB instance and manage their Server users and metadata from there.   Release Version Release Date End of Support (EOS) Version of MongoDB embedded Certified versions of MongoDB supported to connect to user managed instances 2020.1.1.23790 3/5/2020 9/5/2021 MongoDB version 4.0 MongoDB version 3.4, and 4.0, and Atlas 2019.4.4.20206 12/9/2020 6/9/2021 MongoDB version 4.0 MongoDB version 3.4, and 4.0 2019.3.2.15763 9/3/2019 3/3/2021 MongoDB version 4.0 MongoDB version 3.0, 3.4, and 4.0 2019.2.7.63499 7/9/2019 1/9/2021 MongoDB version 3.4 MongoDB version 3.0, 3.4, and 4.0 2019.1.4.57073 2/13/19 8/13/2020 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.4.3.54046 11/14/2018 5/14/2020 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.3.5.52487 10/1/18 4/1/2020 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.1.6 7/17/2018 1/17/2020 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.2.5.48994 7/5/2018 1/5/2020 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.2.4.47804 5/31/2018 12/1/2019 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.1.4.44311 4/2/2018 10/2/2019 MongoDB version 3.4 MongoDB version 3.0 and 3.4 2018.1.3.42973 3/6/2018 9/6/2019 MongoDB version 3.4 MongoDB version 3.0 and 3.4 11.8.3.40692 1/19/2018 7/19/2019 MongoDB version 3.0 MongoDB version 3.0 11.7.4.37815 11/28/2017 5/28/2019 MongoDB version 3.0 MongoDB version 3.0 11.5.1.31573 8/15/2017 2/15/2019 MongoDB version 3.0 MongoDB version 3.0 11.3.3.30523 7/14/2017 1/14/2019 MongoDB version 3.0 MongoDB version 3.0 11.3.2.29874 6/27/2017 12/27/2018 MongoDB version 3.0 MongoDB version 3.0 11.0.5.26351 3/21/2017 9/21/2018 MongoDB version 3.0 MongoDB version 3.0  
View full article
Installing a package from the Python tool is an important task. In this article, we will review all the possible functionality included with the Python method Alteryx.installPackages().
View full article
Issue   When using the Salesforce Input tool, the following error is seen at run-time:   400: Bad Request     This may only occur on some tables It fails almost immediately after the workflow starts running. It may also been seen on the Salesforce Credentials screen along with the error: invalid_grant: authentication failure     Environment   Alteryx Designer Version 2018.3+ Salesforce Input tool Version 4.0 or 4.1   Diagnosis   Confirm where you are seeing the error. If it is on the Salesforce Credentials configuration page when you click Connect, and you see "invalid_grant", please see Solution B.   Otherwise, validate the query to get a more verbose error log.   1. Use the Query Builder option (this is the default option) and select the Table and Output Fields you want to read in. 2. Change to the Custom Query option and click the Validate button:   3. If you receive the error: "OPERATION_TOO_LARGE: exceeded 100000 distinct ids", see Solution A.     Solution A   The data you are attempting to pull is too large to be returned in one call based on the Salesforce API limits used by the Salesforce Input Tool. Limit the number of results returned by modifying the WHERE Clause (SOQL) in the tool's configuration:     Please see the Additional Resources section below for a guide on SOQL (Salesforce Object Query Language). Here are some suggestions:   Try limiting date fields by relative dates : CreatedDate = THIS_YEAR Try limiting a string field to a certain value: Name='SFDC Computing' You can also combine conditions with logical operators like AND & OR: Name='SFDC Computing' AND NumberOfEmployees>25 For more advanced comparisons, you can perform fuzzy matches by using the LIKE operator.  For example, you can retrieve all accounts whose names start with SFDC by using this condition:  WHERE Name LIKE 'SFDC%' - The % wildcard character matches any or no character. The _ character in contrast can be used to match just one character.     Solution B   The credentials are incorrect. Please confirm your Username, Password, and Token are correct.     Additional Resources   Salesforce Knowledge Base - Write SOQL Queries Salesforce Knowledge Base - Reset Your Security Token
View full article
You know that a huge part of conveying information to your audience is your visual presentation. Here's a way to increase the amount of information that can be shared with just a glance: Segment the data in a chart with color.
View full article
With the release of 2018.3   comes   a very exciting new functionality – workflow caching! Caching can save a lot of time during workflow development by saving data at “checkpoints” in the workflow, so that each time you add a new step to your workflow, it does not need to rerun the workflow in its entirety, rather it can pick up from your last Cache point. There are a couple conditions where tools cannot be selected as cache points, including tools with multiple output anchors, and tools in "circles".
View full article