6/17/21: We have completed maintenance for the Search functionality on the Community. If you are seeing any issues, please try to clear your cache first. If the issue persists please email Community@alteryx.com

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

"Your request is prohibited because the request is on loopback from external IP."

MarkelioH
Alteryx
Alteryx
Created

Environment Details


If you are using Assisted Modeling tools in Designer and the machine is behind a Proxy Server, you might get the error mentioned in the article.
 
  • Alteryx Designer + Intelligence Suite
    • 2020.x Versions
  • Third-Party Products: Proxy Server (Manual Proxy or PAC script)
 
Error: "Your request is prohibited because the request is on loopback from external IP."

 
Error: "The request URL could not be retrieved" 


 

Cause


Calls to localhost are not allowed in the Proxy Server.
If the machine when running Designer is behind a manual Proxy server, you may need to allow bypass proxy server for local addresses or add an exception.
If the Proxy Server is configured to use a PAC script, you may need to allow direct access in the PAC script for calls to localhost.

Resolution


Solution A - When using a Manual Proxy server

 
  1. Close Alteryx Designer
  2. Open Internet Options > Connections > LAN Settings
  3. Uncheck the "Automatically detect settings" option
  4. Make sure the manual Proxy server is checked and the "Bypass proxy server for local addresses" is checked as well

 

   5. Restart Alteryx Designer and test the workflow. 
If you are still getting the same error, you might need to add an exception in the Advanced window of Internet Options > Connections > LAN Settings > Advanced


 

Solution B - When using a PAC script

When using a PAC script, you may need to work internally with your IT/Proxy Team to allow direct access in the PAC script for calls to localhost.