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Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

An Unhandled Exception Occurred" when opening Manage Data Connections window

SophiaF
Alteryx
Alteryx
Created

Issue
 

When attempting to open the Manage Data Connections window, the following error is received:

 

An Unhandled Exception occurred.

A previous action may not have completed successfully.

Click OK to send the development team the error log so that we can fix this error in a subsequent release.

 

2018-12-31_12-24-21.png

 

Environment

 

  • Alteryx Designer
    • All versions
  • Windows Operating System

 

Diagnosis 

 

While the above error can occur in another context, this resolution is specific to encountering the error while opening the Manage Data Connections window underOptions > Advanced Options > Manage Data Connections.

 

Cause

 

The GalleryAlias.xml file is corrupted or the file cannot be decrypted.

 

Solution A

 

  1. Close Designer
  2. In File Explorer, navigate to %APPDATA%\Alteryx\Engine
    • The actual path will vary, but it will take the following form:C:\Users\your_username\AppData\Roaming\Alteryx\Engine
  3. Delete the GalleryAlias.xml file

2018-12-31_12-41-29.png

 

4. Restart Designer

 

Solution B

 

  1. In Designer, navigate to Options > Schedule Workflow
  2. Remove all Gallery links by clicking the Trash icon to the right side of the Gallery name.

2018-12-31_12-36-14.png

3. Close the Designer

4. Repeat steps 1-4 under Solution A

5. Re-add your Gallery(s) under File > Save As > Add a Gallery.



Addtional Resources

 
Comments
brindhan
9 - Comet

I was unable to fix this and was at a loss of what caused this error.

Thanks so much!

CristianoJ
Alteryx
Alteryx

I had a user who did not have admin rights to his computer. Usersettings.xml file was not being updated. It is like the designer was not running for the logged user. During installation his IT was installing it in a different user profile than the actual machine user.
We uninstalled and installed the Designer again by making sure the user profile directory was the correct one during the installation process. It was defaulting to his IT admin profile instead of the machine user profile.

it-services
5 - Atom

Muito Obrigado, esse post me ajudou muito. Hoje quando comecei as minhas atividades do nada o alteryx apresentou esse problema.
Inclusive ja tinha excluido e instalado novamente,

 

Obrigado

CristianoJ
Alteryx
Alteryx

@it-services 

 

Fico feliz em saber que esse artigo lhe ajudou a resolver seu problema.

Tenha um bom dia.

tmlmark
7 - Meteor

What could be the cause of a user not having the Alteryx folder in the Roaming folder?  They've performed a clean installation, but there's no Alteryx folder showing up under Roaming as a subfolder.

KylieF
Alteryx Community Team
Alteryx Community Team

Hi @tmlmark,

 

I would recommend opening a ticket with our Support team for this issue. Based on your description it might be an environmental error that they may need more in depth information about. They can be reached at the email support@alteryx.com.

 

Thank you,

KylieF

 

saiHareesh
8 - Asteroid

Hi,

 

I have encountered the same issues, how to find the cause for it as i don't want this issues occurring frequently.

I appreciate your help.

 

Hareesh.

tmlmark
7 - Meteor

A follow up to the ticket we created:

We "found out that issue occurs when running alteryx app file (.yxwz) by double clicking directly on the file from Windows Explorer. For some reason, the Gallery file is created automatically.  Solution: Open alteryx first then drag the .yxwz into the designer and then run."

CristianoJ
Alteryx
Alteryx

I had a customer who had this exact same issue, which started right after upgrading from Designer version 2020.4 to 2021.1.  We found that they had FIPS Cryptography enabled, which is not supported by Alteryx.  Issue got resolved after disabling FIPS.

 

This article below shows how to disable FIPS cryptography:

https://docs.trendmicro.com/all/ent/sc/v3.0/en-US/cmcolh/t_fips.html