Alteryx Designer Knowledge Base

Definitive answers from Designer experts.
The Expert Exam is now live online! Read about the specifics and what it took to bring it to life in the blog by our very own Elizabeth Bonnell!

YXI installation - Fix "Exception" error for long path names

Alteryx Alumni (Retired)



You are trying to install a YXI file and the following message appears: 








An error occurred during installation of the Python tool.





Exception is a generic error message. Frequently, the root cause of this error is related to long file path names when running Windows 10. The following instructions resolve this error when it is caused by long file path names. 


Please note that the following steps require administrator rights


1. Open Registry Editor (regedit.exe)


2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem


3. Right-click on the key and select Export for backup (save the resulting file in a safe place with a meaningful name, like Before_LongPathsEnabled.reg for example)


4. Change the value of the LongPathsEnabled key from 0 to 1





 5. Install YXI file


Note: Restarting computer is sometimes needed to enable change





If provided solution is not possible due to lack of administrator permission for example, then one could use following steps.

The idea is to temporarily shorten the temporary path used during Python module installation. To proceed, we create a temporary drive (T: in following example), then we start Designer to proceed with tool installation, and finally we remove the drive.


1. Open a command prompt and enter the following commands :


subst T: %TEMP%
set TEMP=T:


If T: drive is already in use on your machine then choose another one that is available

You may need to replace "%PROGRAMFILES%\Alteryx" depending on your configuration


2. In Alteryx Designer, click on menu Edit, Open and locate the YXI file for installation

3. Following the installation, close Alteryx Designer

4. Go back to the command prompt and type:


subst T: /D

5. Close the command prompt




As Exception is a generic message, if these troubleshooting steps do not fix your issue please post to Alteryx Community or contact


5 - Atom


I'm new to the community so please bear with me.


I'm getting a similar error.  


I've tried the fix above and restarted my computer. 


However I'm still getting the same error.


Any ideas of what else it might be?  Pic below.



6 - Meteoroid

I am getting the same error. I also enabled longpaths and am still seeing this. Any assistance would be greatly appreciated. 



5 - Atom

For anyone who still gets this error after trying the fix above, contact Support.


You can bypass the installer which is the cause of the error. 


They will send you a link to do a direct download of the file which you can then save directly to a file path that Alteryx Designer will recognize.

6 - Meteoroid

@BCHEN - thank you for the follow-up. I will do that.

5 - Atom

Hi all, I've tried everything but with Alteryx Support help they figured out to make it work this way:


1) You should be able to work around this issue by updating the requirements.txt file inside the .yxi package, to do so, extract the .yxi file using unzip tool such as 7zip or Winzip. And open the requirement.txt files for both big_query_input_v1.0.3 and big_query_onput_v1.0.3. Modify the version of oauthlib and protobuf to the following:



Save the requirement.txt files and zip big_query_input_v1.0.3 and big_query_onput_v1.0.3 into a .zip file, then you can change the extension to .yxi file. The change should allow the tool to install and run properly.


2) Do the workaround solution (detailed above) by executing the command prompt with admin privileges.