Community Spring Cleaning week is here! Join your fellow Maveryx in digging through your old posts and marking comments on them as solved. Learn more here!

Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

Troubleshooting : "Login failed for user" when connecting to an OleDB datasource

JohnGD
Alteryx
Alteryx
Created

Issue

When connecting to an OleDB Datasource using the either the Input Tool or the In-DB Tools, users can encounter the below error message :

JohnGD_0-1576511254872.png JohnGD_1-1576512133420.png

Error opening connect string: Microsoft SQL Server Native Client 11.0: Login failed for user 'user1'.\28000 = 18456

Environment

  • Alteryx Designer
  • Drivers :
    • OleDB Providers for Microsoft SQL Server

Diagnosis

Usually, when testing the Data Connection through the OleDB "Data Link Properties" window they are able to successfully test the connection :

JohnGD_2-1576513246060.png

However the error message will persist from the canvas.

Cause

When mentioning a username/password combination in a connection string, they need to be extracted in the program calling for it.

A parameter will need to be set and added to the string so windowsremembers the credentials and they can be extracted in program.

Solution

  1. Open the Driver's configuration "Data Link Properties" window
  2. Go to the "All" tab
  3. Identify the Persist Security Infoparameter - at this time it should be set to False
    • JohnGD_0-1576515196199.png
  4. Double-click and on this parameter and set it to True
    • JohnGD_1-1576515334445.png
  5. Apply all the changes
  6. Run the Tool on Designer again

Additional Resources

As always, don't hesitate to contact us over atCustomer Supportif you run into any trouble.

Comments
collinsmith106
5 - Atom

This was soooo helpful. Thank you!

dianazamhari
5 - Atom

Hi, 

I tried the step above to change the Persist Security Info to True, however received error as per below.

 

dianazamhari_0-1598852944877.png

dianazamhari_1-1598852945170.png

Did anyone face the same problem?

joshbennett
11 - Bolide
11 - Bolide

Hi @dianazamhari - yes, I got the same error.

athaifa
5 - Atom

Hi @dianazamhari - yes, I got the same error too. 😕

 
 

 

 
 
 
JohnGD
Alteryx
Alteryx

Hi @dianazamhari @joshbennett @athaifa ,

 

Could you please reach out to the support team (support@alteryx.com) with the below details:
- version of Alteryx Designer

- DB + Driver version

- any error message ecountered

 

Thank you,

 

Aditia
6 - Meteoroid

Hi @JohnGD,

 

I am also getting same error. I tried above options, still same :(

 

Output Data (5) Error SQLDriverConnect: SAML response is invalid or matching user is not found. Contact your local system administrator.

 

 

Please help me out!

JohnGD
Alteryx
Alteryx

Hi @Aditia,

 

 

Could you please reach out to the Alteryx Support team (support@alteryx.com) with the below details:
- version of Alteryx Designer

- DB type + Driver version

- any error message encountered

 

Thank you

Aditia
6 - Meteoroid

Hi @JohnGD ,

 

I have already raised case 00539486.

Again raised this case 00539562 with below details:

- version of Alteryx Designer

- DB type + Driver version

- any error message encountered

ntobon
Alteryx
Alteryx

Hi @Aditia, This Knowledge Base article is for Microsoft SQL database using OleDB method. In you case you are getting the error 'Output Data (5) Error SQLDriverConnect: SAML response is invalid or matching user is not found. Contact your local system administrator.' when writing data to Snowflake, so it is a different issue. I have taken ownership of case 00539562 and I will be assisting you. Thank you, Nora