Showing results for 
Search instead for 
Did you mean: 

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Troubleshooting Microsoft Access read/write issues

Alteryx Alumni (Retired)
Created on

Having trouble reading or writing Microsoft Access files? No worries - Customer Support is here to help!


1. Is your file supported?


First thing to check is that your file was created by a supported version of Access. This is taken from our Supported File Formats help documentation page:


Microsoft Access 2000-2003 .mdb Read & Write  
Microsoft Office Access 2007, 2010, 2013 .accdb Read & Write Office or the AccessDatabaseEngine.exe must be installed on the machine running Alteryx.


2. Do you have the right drivers?


You may need to install an additional driver to get the .exe listed above. Download the Microsoft Access Database Engine 2010 Redistributable, which will "install a set of components that can be used to facilitate transfer of data between 2010 Microsoft Office System files and non-Microsoft Office applications."




On some 64-bit Office environments, you may still have to use the 32-bit AccessDatabaseEngine.exe (The 64-bit may still work in these cases, but fail for date/time data types). It's not very clear why this happens, but this Microsoft article discusses some of the advantages/drawbacks of the respective Office bit versions: 64-bit editions of Office 2013.


3. Are you writing out more than 2 GB?


Access .accdb files have a number of limitations you should be aware of, but the big one is a 2 gigabyte size limit.




4. Does your first row of data contain NULLs?


If you're outputting, make sure each of your fields has a representative value in the first row. Sometimes having nulls in the first row will cause the Access drivers to have trouble determining what data type belongs there. Try adding a "dummy" row on top of your data with no nulls.


As always, don't hesitate to reach out to Customer Support if these steps fail to resolve your issue.



This worked great!  Thank you for such an informative solution!

Alteryx Certified Partner
Hi AlexKo I have some ACCDB read issues. Tried installing the Microsoft Access driver (2.00.4518.1014 specifically), but I cannot see all Access queries when trying to fetch data from an Input tool? Hope you can help! Jess
Alteryx Certified Partner
... and furthermore, your "Supported File Formats help documentation page" link above gives me "Access Denied"
Alteryx Alumni (Retired)

Jess, the topic was updated and relocated, you can access it here: Supported Data Sources


Does anyone else have the issue where MS Access goes through a long installing process every time you open it after installing the above AccessDatabaseEngine file? It also takes a while when first opening a flow that has an input or output to Access. I'm thinking I need to get IT do something else with my machine to fix this new issue but at least now I can read and write to Access files if needed.


@AlexKo Do Nulls or Empty Strings cause an issue in row 1 or just Nulls? (i.e. Can I add a Data Cleansing Tool before the output to resolve?)

Alteryx Alumni (Retired)

Hi @AmeliaG - If memory serves I believe that empty strings have the same problem as Nulls. Good luck!