Showing results for 
Search instead for 
Did you mean: 

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

The 'How to Guide' to the Salesforce Connector

Created on


The improvements in our salesforce connectors have been astronomical over the last year and now it is easier than ever to navigate the UI configuration screen and connect to your Salesforce Data.


From here in the Salesforce connector will refer to both the Salesforce Input and Salesforce Output


There are a few things you will need in order to use the salesforce macros

  • To use this tool you will need to have access to
  • You will need permissions to either read Salesforce Input and/or write Salesforce Output
  • You will need the internal server URL (Find this here)
  • Your specific Username and Password
  • Your salesforce security token

Step 1: Find your URL

Step 2: Username and Password

  • Use the same username and password for
  • Type these into the respective text boxes

Step 3: Security Token

  • Please see this article to retrieve your security token

Step 4: Connect

  • Once you have entered all the information you should be able to connect and the configuration window will change to the Table and Optional parameters

Pic 1.png


Step 5: Choose a table and Output Fields

Once you choose a table it will automatically populate with the available output fields. In the drop down you will have the option to select multiple output fields if you would like.


Pic 2.png


Step 6: Record Limit and WHERE Clause (SQQL)

You can choose a record limit and choose to be more specific in your table search using the WHERE clause. For example, I may want to only look for a specific Account in the salesforce table, so the statement would look something like Account = ‘Jordan Barker’.


Pic 3.png


Step 7: You've done it! Run the workflow!

Once you have entered all of the necessary information you can now run the workflow and retrieve the Salesforce data.


Tips and Tricks


Check First

Make sure from your Salesforce Admin that you have the necessary permissions to read and/or write tables. If you do not have these permissions you will receive a salesforce error from the tool.


Try some sample data

Depending upon the amount of data you are pulling into Alteryx it might be worth just doing a test with some sample data. Once you have confirmed the configuration is working correctly leave the record limit box empty and it will return all records.


Change credentials

If you want to change your credentials please select the change credentials hyperlink on the second configuration screen in the tool.


Pic 4.png


Check your tables!

When using the Salesforce output tool all tables need to exist. This tool will not create new tables in Salesforce.


Password Expiry

If your password expires in Salesforce you will receive a pop-up error message in Alteryx. Currently, there is no Alias option for the Salesforce Connector therefore if you're password expires you will have to manually go and change it in each connector. This is something we are looking at internally to try and create an Alias for similar to that available with the database connections. 


For the time being the easiest alternative is to have your salesforce admin create a generic login and set this password to never expire. If this is not an option you can go to User Settings > Advanced > Disable Auto Config and this will allow you to change the password in your salesforce connectors without getting locked out and the error message popping up.


Common Issues


‘Error: Salesforce Output: The following fields are not members of the target table’


  • Please check that all the tables and output fields exist. As stated above the Salesforce Output tool will not create new tables or fields


‘Salesforce credential disappearing'


  • Please check to see if you have read/write/modify privileges for three directories that the connector uses.
  • C:\Program Files\Alteryx\bin\RuntimeData\Macros\Supporting_Macros,
  • Default macro directory (you can find the path in Options >> User Settings >> Edit User Settings >> Macros, take the search path from there)
  • Temp file directory (you can find the path in Options >> User Settings >> Edit User Settings >> Defaults, listed under “Default Temporary Directory”)?
  • Just right click on each one of those folders and select “Properties.” In there, just make sure in the General tab that read-only isn't selected.
  • You should also navigate to the Security tab to double check that your user group or username is listed with full access.
  • Please also check to make sure these directories aren't running out of space.


‘Access Denied’


  • Please check your permissions to the tables and output fields with your Salesforce Admin


‘Error Sending Request URL Using bad illegal format or missing URL’


  • Please use and copy and paste the URL into the configuration window


'INVALID_LOGIN: Invalid username, password, security token; or user locked out' or 'Alteryx doesn’t support connecting to Salesforce without the security token'



  • Locate the SFDC plugin within your 10.6 installation (for admin this will be likely be C:\Program Files\Alteryx\bin\HtmlPlugins\SalesForceInput, for non-admin C:\Users\[your user name]\AppData\Local\Alteryx\bin\HtmlPlugins\SalesForceInput) and make a backup of this folder to be able to revert if necessary
  • Overwrite the contents of the above folder with new files here


As always if you have any issues please do not hesitate to reach out to Support

Have you seen the issue where the list of tables to choose from does not include all Salesforce tables? It's supposed to be possible to type in other table names and use them, but I've found that Alteryx ignores/doesn't respond when I try typing in table names that I know exist.
Any suggestions for this problem?


Hi Asteryx,


What I have seen in past is we can type the (full) table name, it might not work exactly like typing a part of the table name and getting the entire table name as a hint. But if one types the entire table name and then clicks somewhere outside in the workflow designer canvas/pane it has worked for me.



Rohit Bajaj




I'm new to Alteryx and have a question about pulling data from Saleforce. I was pull data from Salesforce objects, but our group mainly use the data from a few reports, which we built using quite a few custom fields. Is there a way to pull data from Salesforce reports?




Hi Vincent,


Looking at the below post ... seems it is not readily available.



Rohit Bajaj



Thanks Rohit. I contacted Alteryx sales and support teams and they confirmed that it is not available currently, but on the roadmap.

I have posted a new idea in the Allteryx Idea Center as they suggested. Please encourage folks who may need this capability to "Star" it:



Thanks all,





Sign into this website  ( and you can see all the tables you have access to. If you are not seeing them here you need permissions changes or in some cases licenses. 


For example, using the Alteryx SalesForce Read tool I do not see OpportunityLineItem however it does show up using this website.The Alteryx tool can read the table when I explicitly type the table name in.



Hi - does the Salesforce connector automatically default to using the '18 Digit ID?'


For example, the contact table has both an 'ID' field and an '18 Digit' ID' field. When using these fields in Salesforce directly:


ID = 15 Digits

18 Digit ID = 18 Digits


However, when using the Salesforce connector, the 'ID' field is now 18 digits long. Essentially, there is no 15 digit contact ID field available to use. Do you have any insight?



How can we do achieve upsert functionality in salesforce environment?




@tpxmetsfan14, I believe the 18-digit ID is the same as the 15-digit ID if you just remove the last three characters. The last three characters turn the 15-digit IDs into case insensitive values, so, for example, 123BbBbBbBbBbBb is treated as the same by some applications as 123bBbBbBbBbBbB, but with the 3 extra characters, these two will always be different regardless of case.


@vijayasaharan, It looks like the Salesforce output doesn't have upsert available:

I would investigate pulling all the data in to Alteryx first and deciding in your workflow what needs to be inserted and what needs to be updated and then send that into Salesforce appropriately. I haven't done this, so it's just an idea for you.


Thanks, I went ahead and did it (pull all data from salesforce, do a join with an external ID and do one insert and one update operation). It all worked out great.  


I have one more question. I would like to send an email once my process runs, I found the events window and I was able to get the basic email, but my question is how can I get some custom data. Lets say I inserted 40 records and updated 120 records. Is there a way I can do this?


Also how can I update a field in salesforce to indicate that this load complete in another table after the insert, how can I do this? I can not go add another salesforce output to the salesforce output. Any direction would be really.



Your second question looks like something for a new thread - it's not related to the Salesforce connector.

Maybe someone else will chime in with an answer to your second question. I'm not  an expert on outputs - just trying this myself, now. My first guess is to use a Stop Until Done tool (or is there a newer version of that now?), but you still need to collect a relevant ID field from the first task so that the "complete" field refers to the correct event.

Good luck.


Is anyone else getting an error when trying to install the SalesForce Input tool?Capture.PNG




Please contact with this error message.





Alteryx Partner

@JordanB wrote:

Change credentials


Password Expiry

If you're password expires in Salesforce you will receive a pop up error message in Alteryx. Currently there is no Alias option for the Salesforce Connector therefore if you're password expires you will have to manually go and change it in each connector. This is something we are looking at internally to try and create an Alias for similar to that available with the database connections. 


For the time being the easiest alternative is to have your salesforce admin create a generic login and set this password to never expire. If this is not an option you can go to User Settings > Advanced > Disable Auto Config and this will allow you to change the password in your salesforce connectors without getting locked out and the error message popping up.


Hi Jordan

Can you confirm whether this has been addresses yet please?



As a workaround,we have created an account and have set the password to not expire in salesforce . I know this is not an answer to your question, but just a suggestion.

Sent from my iPhone

@Analytics_Flow this has not been addressed in the tool to date. Please feel fee to suggest this in the ideas section of the designer.


If a generic password (service account) option is viable I would suggest using this option.





Alteryx Partner
@Analytics_Flow: If that helps, I came up with a hack that works very nicely to update all those connectors at once:

Thanks for the hack @fpinchon. Haven't tried it yet, but it looks useful. (And it also shows a security weakness of Alteryx!)

I believe the current version of the connector no longer does the thing where it tries to connect to SForce first, at least.

Alteryx Partner
@asteryx I would not call it a security weakness, since the password and the token are encrypted...

I shouldn't have been so brief - the reason I think it's a bit of a loophole, even though it's encrypted, is that if someone had access to the Alteryx file then they could log into Salesforce under someone else's account. The encryption doesn't prevent that. Or am I missing something?

Alteryx Partner

If someone gets access to your Alteryx file, that means they have access to your hard drive, so you may have a bigger problem on your hands...

But yes, credentials are sometimes included in the workflow, for SFDC connectors for instance.

However, other connectors are not much safer, since with access to your hard drive, someone could get to your ODBC connections and get access to all the systems you have configured as well, so I don't draw a big distinction here...


I see your point. Gonna stop beating this dead horse now. 🙂



The salesforce connector has to be one of the buggiest connectors I have ever used.  Are there any plans to improve it?  


@ISUGraber- I haven't experienced any significant buggy behavior with the Salesforce Connector. Maybe you could describe your issues and be more specific about improvements you'd like to see.


1)  If I need to make a minor change to my workflow these are the steps I must take.

               A)  Download workflow

               B)  Update all of my passwords with salesforce connectors.  Which is a multi-click endeavor for each object.

               C)  Copy workflow over to Alteryx server

                D)  Open workflow from server in 2 windows, delete all objects in one I am replacing, copy new workflow objects from old workflow into new one.

               E)  Update all of my passwords again.

               F)  Run and verify it works before uploading.


So if you could make it so I didn't have to re-enter my password several times that would be great.  Also, being able to update the workflow from my laptop would be awesome too.  Or even better, allow me to have 1 object that has my userid, password and token in it and that object passes that information to all of my other objects so I only have 1 place I have to change my passwords.  That would be even better.


I've had issues in the past where it decides it doesn't like me and I've had to re-enter my credentials several times before it does.  Next time that happens I'll try to send screenshots.  


@asteryx  on top of the above annoyances my Salesforce workflows are plagued with this annoyance.  I hit "Debug" and it lets me continue.  But this pops up every so often.  Although I'm not 100% sure it's salesforce's fault.AlteryxError.png


@ISUGraber- I don't have answers for you (I don't work for Alteryx), but it's good to see these on the forum so they know about them and so others who may have the same problems can contribute their experience.

As for the password issue, it looks like others in this thread have made some progress on work arounds. Otherwise, your comment sounds a bit like an idea worth submitting (

And with the Alteryx crash, I would contact support about that (and post the result here). I haven't seen that happening.


Good luck.


Thanks @asteryx for a second I thought you did.  Then I thought your name reminded me of Asterisk and Obelisk.  But thanks for the tips I'll follow them.


Nice to see another fan of the Gauls out there, @ISUGraber.


Hi - Urgent help needed. I can connect to the input tool just fine but when I try connect to the output tool , the list of tables doesn't show up.




You may have done this already, but to cover all the bases, check these:

- copy the URL and paste it into a browser - you should be able to log in to the expected instance of Salesforce from there with the same user name

- double check your password and token - copy paste them from the input tool that works (and you can do the same with the URL and user name, too)


I believe the issue is with the connection to Salesforce. I doubt it's a write permission issue with your account since it's only trying to connect at this point.



@asteryx thank you - I have indeed tried that with no luck. Do you think It could be the tool itself. When I look at the GUI file it doesn't even feature the table select part. 




So - does your configuration get stuck at the credentials screen? Or do you see something like this - but without any tables in the dropdown:

SForce Output.PNG

My xml does look different than yours (I edited out some info):

SForce Output2.PNG

I'm not sure if we're looking at the same thing, though. The format is different. The above is from the second button on the config screen of the output tool. Where did you get the GUI file?

I'm using Alteryx 2018.3.

From your screen shot above, I believe you are not using the deprecated version of the Salesforce connector.



@asteryx I don't get to that screen on the output tool. I enter my credentials, hit connect and then nothing happens. Well that red box appears under connectScreenshot_11.png


Hmmm. I'm running out of ideas. Might be a case for Alteryx support, after all.

I am curious where your GUI file comes from. Did you get it from the same place I describe above (the icon that looks like "</>")?

If so, maybe you need to reinstall the Salesforce connector tools. Maybe the output tool got edited?? (I've never done that and I'm still unclear on whether doing so changes the tool or creates a copy.)

If not, can you explain what you're looking at there? (It probably won't help, but I'd just like to know. 🙂 )


I hope you figure it out (and then post your solution).



@bwoofa I would log this with Alteryx Support






THanks JordanB. Will do.


Ok this fix everyone is to use the classic URL and not lightning. I found this to be strange as the lightning URL worked for the input tool. Thank you for your kind help! I hope this helps someone else.




I have a question about this message: 


"Since the last time this tool was configured, the following fields have been dropped from the Salesforce object:"


After that there is a list of fields that I cannot find anyone.

A few fields that are in this list are used in my workflow, so now it doesn't work as the fields are missing. 


When I go to the SalesForce website, I still see the fields that I was downloading, but cant find them anywhere I looked in different tables in Alteryx. 


Any ideas why this happened? Or how to return the fields that I need? 


Thank you


Hi @Torao  


I would verify this with your Salesforce Admin. The interface reflects what is being returned from the API call.