Issue
Unable to log in to Alteryx Server using Built-In Authentication from Alteryx Designer when using correct user credentials.
"Email or Password were incorrect. Please try again."
Environment Details
- Alteryx Designer
- Versions 2021.4 and older
- Alteryx Server
- Versions 2022.1 and newer
Cause
A change in the password hashing algorithms in Alteryx Server and Designer versions 2022.1 and newer, prevents users from logging into Server from Designer when using Designer versions 2021.4 and older.
Diagnosis
- Confirm the version of Alteryx Server being used.
- If you are using version 2021.4 or older, you are not experiencing the issue described in this article.
- Confirm the version of Alteryx Designer being used.
- If you are using version 2022.1 or newer, you are not experiencing the issue described in this article.
- To confirm the "Email or Password were incorrect. Please try again." error is due to this issue, log in to your Gallery directly from your browser, using the same credentials being used to log in from Designer.
- If you are able to successfully log in, please see the resolution below.
- If you are unable to log in, please contact your Alteryx Gallery administrator as the issue is likely due to incorrect user credentials.
- If you're still experiencing this issue after you're able to log in to your Gallery via browser, please see the resolution below.
Resolution
- Upgrade Designer to the same version as your Alteryx Server. Do not upgrade to a Designer version that is newer than the version of Alteryx Server being used as it may lead to workflow compatibility issues.
Additional Resources