Issue
The Input Data tools throw the error below when a folder name within the root directory of a mapped drive starts with a period "." character. This is frequently seen with Google Drive directories as they start with G:\.shortcut-targets-by-id, but it is not an issue specific to Google Drive.
Can't find the file: "[path\FileName]". Make sure the file path is correct.
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Additionally, users may experience either of the following issues as well:
- The Alteryx workflow in one of these directories may not open.
- If the Alteryx workflow has a macro saved in one of these directories, the workflow will fail. The following error may also be thrown when attempting to reopen the workflow.
This workflow references macros (_externals\1\MacroName.yxmc) that are missing or inaccessible. Saving this workflow will permanently disable these tools.
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Environment Details
Cause
Known product defect TCPE-17.
Resolution
This product defect TCPE-17 has been resolved in Designer version 2021.4 and later.
Workaround A
- Rename the folder to remove the period.
Workaround B
- Relocate the folder that starts with a period to a sub-directory. Note that this issue only occurs when the folder name within the root directory has the period.
Workaround C
- Upgrade to Designer version 2021.4 or newer, or Downgrade to Designer version 2021.2 or older.
Additional Resources