ALTERYX INSPIRE | Join us this May for for a multi-day virtual analytics + data science experience like no other! Register Now
2 Day Countdown - The Alteryx Community will be temporarily unavailable for a few hours due to scheduled maintenance starting on Thursday, April 22nd at 5pm MDT. Please plan accordingly.

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Publish to Tableau Server - Error: The file was not uploaded successfully

christophermtorres
Created

Environment Details


  • Alteryx Designer
  • Alteryx Server
  • Publish to Tableau Server tool
    • 2.0
  • Tableau Online
    • 2020.4

Error: The file was not uploaded successfully.



Cause


Tableau updated their API responses in Tableau Online version 20.4, which causes Alteryx Connector to show an error. This can be worked-around by modifying a Filter tool inside the Tableau macro Connector tool [API response is now "201" instead of "201 Created"].

Note: Our development team is currently investigating this issue caused by the Tableau side API changes. This post will be updated with more detail when available.



Resolution


1. Open the workflow in question that is showing error. Right-click the Publish to Tableau Server tool and select "Open Macro". This will open the workflow which is the Tableau Connector tool itself.

2. Go to Edit > Find, type in "257" and select Filter tool #257.

3. In that Filter tool update the Custom filter entry to:

findString([DownloadHeaders],"HTTP/1.1 201")>=0


Example screenshot:

    


4. Save the macro and rerun workflow in question. Note: Saving the macro will update the tool on the machine - not just for the specific workflow. You may run into a permissions issue "Access is denied" when saving. Please ensure the user making changes is in a group with full control for the path: C:\Program Files\Alteryx\bin\HtmlPlugins\PublishToTableauServer_v2.0.0\Supporting_Macros or for the PublishToTableauServer.yxmc directly. 

Comments
MarshallG
8 - Asteroid

We are still using a 1.09 version of the Publish to Tableau Server output macro and are receiving the same error having recently upgraded to Tableau Server 2020.4.

 

We have been unable to get the v2.0 Publish To Tableau Server macro to correctly connect to Tableau Server due to credential/connection issues, hence our continued use of 1.09.

 

Can you please supply a similar workaround as above for the v1.09 Publish to Tableau Server macro? We have many workflows that are being run via Scheduler and the Error makes it very difficult to monitor what has successfully run vs failed.

MarshallG
8 - Asteroid

 

Workaround For Publish to Tableau Server macro version 1.09

 

Note: workaround below is not (yet?) Alteryx endorsed but it worked for us

 

The filter referenced in the v2.0 workaround exists in the v1.09 macro as well, however it is embedded in another custom macro. So, you'll need to find and open with Alteryx this file wherever the Publish to Tableau Server macro was installed:

 

TableauServer.PublishTDE.yxmc.support

 

Then use 'Find' tool as in workaround above but now looking for tool ID: 30

 

You will see the same filter as noted in Alteryx workaround in original post above and you can change the filter with the same code snippet referenced above.

 

MarshallG_0-1612293471246.png

 

MarshallG_1-1612293580531.png

 

jrgo
13 - Pulsar

@christophermtorres 

 

Can we expect for this to be fixed on 2021.1 as well as older releases?

Ed-Alcon
5 - Atom

I have a user who is having an issue. She is on 2019.4 Alteryx with the 1.09 macro. When she does the search  for 257, she gets the wrong response from the macro:

Ed-Alcon_0-1612970539077.jpeg

Do you have any idea as to what is happening?

 

Thanks!

MarshallG
8 - Asteroid

@Ed-Alcon  The original solution (editing tool #257) applies only to the version 2 macro.

 

Please see my solution for v1.09 that requires editing tool ID 30 in this file: TableauServer.PublishTDE.yxmc.support that was downloaded/extracted when you originally downloaded the Publish to Tableau Server macro.

JoshML
Alteryx
Alteryx

This behavior was addressed with the 2021.1 release of Designer. The entirety of the release notes can be found here.