Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

My .tde file is only 30k in size, it should be much larger


Every so often we get questions about a .tde (Tableau Data Extract) file that is being output from Alteryx that has a file size of 30k when the original data is much larger. When the file is opened in Tableau this error sometimes comes up:


An error occurred while communicating with data Source ‘yourfilename.tde’


Tableau error.png


The last couple times I’ve helped troubleshoot this it came down to a field or fields in the data that ultimately needed to be a V_WString data type in Alteryx to accommodate for a some Unicode characters (think Japanese or Chinese characters, symbols like ♥ or © or even letters like ñ and ó).


Sometimes it may not be easy to identify fields with those characters. “So how do I find them?” you ask.


Here are a couple things to try:

  1. If your table isn’t too large scan through it to see if anything pops out.
  2. Try saving each field out as a file all to itself. If a file is 30k in size it is worth investigating that field of data. To try this method use a Select Tool to select one field at a time and then save it to a .tde file.  The results may look like this:

file check.png


So the possible trouble column has been identified, now what?  Examine the field to see if there are any characters that may be ‘out of the ordinary’. Then in either an existing Select Tool or by adding a new one, find the field in question and change its data type to V_WString and try saving it to a .tde again.  If the file size is different that 30k it may have corrected the issue.


select tool fix.png


So what if there are too many fields in the data to save them out one by one manually? Batch macro to the rescue!  Create a batch macro to loop through each field and save it out to an individual file for examination.


A workflow is attached (created in Alteryx 10.6) that shows an example of a file that saves incorrectly to a .tde, that is fixed and saves correctly to a .tde and includes an example of a macro that saves each column as its own file.

Alteryx Partner

I'm also getting this error (randomly) when I'm writing to a folder that also sync's with Dropbox.  If the output tool takes too long to write to file you get a 30kb TDE and a larger PKG file.  The quick workaround for me is to pause syncing in Dropbox then re-reun the workflow and it works.

Alteryx Alumni (Retired)

Came in handy recently - thanks for sharing @PeterS!

9 - Comet

This was a life-saver today!




5 - Atom

Saved my life!! Thanks

Alteryx Certified Partner

cmcclellan - Thank you! Complete life saver, I was using a process that was zipping up my tde files to create zips as soon as they were created so I had been wrestling with this for months!





Alteryx Partner

Same symptom & error. Changing the column type from V_String to V_WString resolved my similar issue. Thanks a lot Peter!

6 - Meteoroid

@mix_pix @gtaramasso  Sound familiar? 

6 - Meteoroid

@cmcclellan did you ever try the solution listed by PeterS?  I am wondering if the two approaches solve the same problem or solve different problems...

Alteryx Partner

@joeschafer, it's 2 different problems IMHO.  Peter is talking about when there are datatypes that are not compatible with Tableau, I'm talking about when the writing of the file is interrupted by something else.  In my case, I always use Dropbox and can always fix the "30k TDE problem" by pausing Dropbox for a while.  On small file writes there's no issue because the writing is finished before Dropbox polls the directory for changes, but on longer writes you need to stop Dropbox polling (I'm guessing Dropbox locks the file which is the reason why Alteryx can't write to it any more, but I've never worried about debugging it that much).



8 - Asteroid



I've just encountered this exact problem.  It's a real pain, especially as I'm prepping for month end next week and wanted everything to go smoothly.


My colleague Gavin is currently working on a work-round.  Incidentally, changing the fields to a VW_String hasn't worked for us as the file is still 30kb.

5 - Atom

I having the exact issue and changed all strings to vw_string but continue with the same error...any other thoughts on what actions to take?

8 - Asteroid

Thank you @PeterS


Life Saver.


Best Regards