Showing results for 
Search instead for 
Did you mean: 

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Microsoft Access .accdb Input

Created on


How come I cannot find my .accdb Access database when I use an Input Data Tool and try to search for it?


In order to open Access databases with the .accdb extension, you will need to download the Microsoft 2010 Office System Driver: Data Connectivity Components. Once you download and install, you will just need to close Alteryx if it is open and restart. You will then have 'Microsoft Access (.accdb)' as an option in the Input tool's File Browse drop down:


9-27-2016 2-17-03 PM.png


Do they have this for 2013? 


Hi @Lizzie. Sorry for the late reply. This should work for MS Access 2013 as well. Thank you!




Sure thing, @Lizzie!


We are having the same issue with Alteryx 10.1 and Office 2016.  We tried the Office 2016 Database Engine Redistributable and that didn't work.  Will this work for our setup?

@todd_henry I would download the 2010 Database Engine referenced in number 2 of this article. You will presumably want the 32-bit versions if you have a "normal" setup. 




To preface, I just started using Alteryx in the afternoon yesterday - it's fairly intuitive and I think I have a workflow largely the way I want it (Salesforce joined to MS Access, with 3 additional Access tables joined across by position), however when I reference my Access file, I don't see an option for a query in Access I've made. So far I haven't seen any literature referring to this, so how do I reference my Access query, or do I need to write SQL through Alteryx to push it up?


Any help appreciated,




Thank you!

Hi, This solution worked and I was able to see MS access files while on Office 2016 but my company recently upgraded to Office 365 and it no longer works. I can see in my programs list that the Microsoft Access database engine 2010 (english) is still installed. Is that expected? or should it still be working?

Alteryx Certified Partner

Worked fine, Thanks!

Alteryx Certified Partner

Thank you

Thank you good stuff, this worked for a colleague who was having a problem connecting to accdb files. We checked versions and 64 bit vs 32 bit and were confused that locally installed Access could open the files with no problems. We installed the data connectivity components and it worked immediately. The dead giveaway for this is if you can't see accdb in the list of available file types in the input tool. If you can see it there then you probably have a different problem.