Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Intelligence Suite tools missing

MatthewP
Alteryx
Alteryx
Created
You have an active license key for the Intelligence Suite but some or all the above tools are missing from the Tool Palette and they are not hidden by unchecking the "+" icon on the right side of the Tool Palette as shown below:


 

The tools did not install properly. You can confirm this by also looking in one of the two locations based on if you are working in Admin or Non-Admin version of Designer (confirm which one from the Help > About menu within Designer)
  • C:\Users\<USERNAME>\AppData\Local\Alteryx\bin\HtmlPlugins (Non-Admin version)
  • C:\Program Files\Alteryx\bin\HtmlPlugins (Admin version)
If the tools were installed, in one of those locations you should see folders with names that mirror the tools themselves as shown here:



Reinstall the tools by following these steps.
  1. Navigate to one of these two locations based on if you are working in Admin or Non-Admin version of Designer (confirm which one from the Help > About menu within Designer)
  • C:\Users\<USERNAME>\AppData\Local\Alteryx\bin\PythonConda\YXIs (Non-Admin version)
  • <Install Path>\Alteryx\bin\PythonConda\YXIs (Admin version)
  1. You will see two YXIs. If you double click them (one at a time) you will be prompted to install the tools.


NOTE: For Versions 2021.1, please see the list of the YXIs in this screenshot:

 
  1. Click "Install". The install process might take some time depending on resources of the computer and other factors. 
  2. Once the install  is complete you will have a message saying it succeeded and then a total elapsed time. The tools should now be available on the Tool Palette. 


 
 


No ratings
Comments
ChrisMelck
8 - Asteroid

I am missing a few tools (specifically the PDF input tool). I tried to diagnose the problem using the above (I have a non-admin version). 

 

I have a PDF input folder here : C:\Users\<USERNAME>\AppData\Local\Alteryx\bin\HtmlPlugins 

 

So it doesn't seem to be this problem. Is there another reason why I can't find my PDF input tool? (I have check that it's not just hidden)

 

Thanks