Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Installation stopped on Python Dependency window

Loredana
Alteryx Alumni (Retired)
Created

Environment Details


  • Alteryx Designer
    • Version 2020.1+
  • Alteryx Server
    • Version 2020.1+
After launching Alteryx Server or Designer installer, the installation stops on the Python Dependency Window for a long time.

Cause


One of the python sub-proccess is stuck. Review the below to confirm:
 
  1. Launch Alteryx installer.
  2. Allow the process to proceed with the installation.
  3. When reaching the Python Dependency window, let it run for a minimum of 25 minutes.
Note: This step takes between 16 and 25 minutes depending on the Resources allocated to the Server or Local Machine.
 


Resolution


This is a known issue that Alteryx is researching - follow the steps below for a workaround.

1. Open Task Manager and go to the Users Tab.

2. Expand the user that is installing the application and look for a python process (python.exe) with about 10 to 13 MB in memory but with 0% CPU committed to it.



3. Right click on the 0% CPU process and press End Task.
4. After this another python process normally shows up and the installer should proceed as normal.
No ratings
Comments
hellyars
12 - Quasar

@Loredana  THANK YOU.  I run into this issue every upgrade cycle.  As a Mac user, this is alien and highly frustrating.  

sigmol89
5 - Atom

@Loredana Perfect solution.

Works like a charm. 

Rendra
6 - Meteoroid

Thank you, this solution solved my issue.

Paul_Holden
8 - Asteroid

My experience was that the process that was taking up the most CPU whilst the installer was "hung" was anti-virus. We assumed that the Python install was deploying a large number of small files that was causing AV to choke.

 

Interesting to see that in your case there is no obvious AV issue.

JirkaD
Alteryx
Alteryx

I got a similar issue when trying to install AlteryxServerInstallx64_2020.3.4.30228.exe. The same screen but no pending Python processes. Nothing suspicious with AV activity either. Average CPU utilization below 10%.  Tried two times in a row with a reboot in between, let it work for 90 mins+ but no visual progress.

 

***UPDATE***

The issue was solved by selecting another subversion of the installation file for 2020.3, specifically AlteryxServerInstallx64_2020.3.9.30296.exe. After that everything went smoothly.

VijayAnaparthi
7 - Meteor

Thank you. This will solved my problem.