Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Error: "Microsoft Visual C++ 14.0 or greater is required" when installing Python library 'pandas-dedupe' in the Jupyter Notebook interface

Suskil
Alteryx
Alteryx
Created

Issue

Trying to install a Python library pandas-dedupe in the Alteryx Jupiter notebook interface.
Tried both
  • 'from ayx import Package Package.installPackages(['pandas-dedupe'])'
  • 'from ayx import Alteryx Alteryx.installPackages(['pandas-dedupe'])
The following error is shown in the stack trace:
 
error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/

Environment Details 

  • Alteryx Designer
    • Any
  • Python Tool


Cause

 

As error message indicates, the libraries are included in Microsoft Visual C++ 14.0 and above. 



Resolution

  1. Download Microsoft C++ Build Tools
  2. Execute the installer and select the following to install image.png
  3. Once installed, launch Designer and add Python Tool
  4. Uncomment and complete Package.installPackages(['pandas-dedupe']) 
image.png​​​​​​​


Additional Resources

No ratings
Comments
qrodrigob
5 - Atom

[Solved] - Step for Step
Microsoft Visual C++ 14.0 is required
https://youtu.be/Y4QxGemfNrs