community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Data source name not found and no default driver specified

Alteryx
Alteryx
Created on

Issue 

 

The Alteryx server is unable to run a workflow that runs properly on the user’s local machine where the workflow was created. 

 

[ODBC Driver Manager] Data source name not found and no default driver specified alteryx


This error can be encountered when running an app or workflow on a Gallery:

galleryerror.PNG

 

Or when uploading a workflow during validation:

 

savegallery.PNG

Users will also receive the following error when opening a shared workflow where the Data Source Name does not exist on the user’s local machine:

 resultserror.PNG

 

 

Environment

 

  • Alteryx Designer
  • Alteryx Server 
    • Version ≥ 11.0
  • A workflow that contains a Data Source Name (DSN) on the Input Data tool.

 

Diagnosis

 

Confirm that the data source name (DSN) specified in the workflow is pointing to an existing DSN in your machine’s ODBC Data Source Administrator:

 

***You must have the driver installed on the machine prior to using this guide. The download links to many of the drivers can be found here.

  • On your local machine, search for ODBC Data Sources (64 bit)
  • The DSN referenced in the input data tool within the workflow must be listed under either User DSN or System DSN tabs.

odbchighlighted.PNG

 

Cause

 

The workflow is not able to successfully run because the input data tool cannot reach the database in the following scenarios:

  • The workflow creator sends a workflow with a database connection to a colleague who does not have the same DSN on their computer.
  • The workflow gets sent to the alteryx server to run on a scheduled frequency where the DSN does not exist on the server machine.

 

Solution

 

  1. You must have the driver installed on the machine prior to using this guide. The download links to many of the drivers can be found here.
  2. Once confirmed that the appropriate driver is installed, select to add from either the user DSN or System DSN tab. Generally, the User DSN is what most users will have access to and what is commonly used. You can learn more about the difference between User and System DSNs here.

  3. In order to resolve the error at the local level or on the Alteryx Server, you will need to set up the corresponding DSN found in the app/workflow. The following Community article will provide you step by step instructions on how to set up an ODBC connection.

  4. Once you've established the DSN on your machine, you will now be able to successfully re-run the workflow!