on 06-28-2018 09:26 AM - edited on 08-03-2021 03:38 PM by csalgado5
Issue
Intermittently, but more often than not, when a workflow is run it fails, and the following error pops up in the results window:
Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamedPipe: Error in ConnectNamedPipe The pipe is being closed.
Environment
Diagnosis
In Support, we have frequently seen this ConnectNamedPipe behavior associated with adaptive threat protection (also known as Endpoint protection)McAfeeand Malwarebytes have been proven to cause this issue so far, others may cause it as well. If you are seeing this error, and have any of the above antiviruses on your machine, try the following to validate whether you are seeing the same behavior:
3. Try working with your IT teamto temporarily disable the McAfee ATP, and see if the error goes away entirely.
1. If you are able to run workflows without issue while ATP is disabled, you have identified the cause of your error!
Cause
TheEndpont/Adaptive Threat Protection functionality is interacting with internal communications in the Alteryx Designer software and causing a delay, resulting in a timeout. Even though the antivirus isn't taking any action on Alteryx (no blocks, no detections, etc.) the presence of the antivirus module, which is essentially an application sandboxing capability, can cause timing issues within our application.
Solution A
Work with your IT team to whitelist (create an exception for) the attached list of files, which Alteryx needs to run. The files are separated by type of installation, and the file paths may be different depending on your installation.
Solution B
Work with your IT team to Disable the Antivirus. Please note that this should only be a temporary measure to determine if the antivirus is actually causing the issue.
Additional Resources
i'd also suggest validating that you try switching your Admin vs non-Admin version, either direction
This solved the problem for me - stripped out the non-Admin version and installed Admin, without the need (so far) to do anything with McAfee at all
Note : another user did mention that it was probably just that IT had whitelisted the Admin version and went no further..
but in any case, may be a good short term fix for whomever might be interested
Hi Sydney,
I was too lazy to do the things you recommended. I couldn't figure out how to write the McAfee ATP whitelist and some of the other stuff. I needed a quicker solution, so I found one. At least this solution works for me. I can now go surfing with Alteryx because my pipeline is staying open. Hopefully, this helps others, too. Youtube video of my solution.
Ken
Hi all,
I can confirm that disabling the cloud-based scanning option in the Adaptive Threat Protection's Real Protect Scanning section fixes the Designer x64 The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamedPipe: Error in ConnectNamedPipe The pipe is being closed. issue in our McAfee Endpoint Security deployment at work, see images below.
1. Click on Adaptive Threat Protection.
2. Deselect the Enable cloud-based scanning option, and click Apply.