community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Cannot find macro: Publish To Tableau Server

Moderator
Moderator
Created on

 When attempting to publish a workflow to your private Gallery which contains the Publish to Tableau Server macro, you may encounter an error similar to this:

 

Cannot find macro "PublishToTableauServer_v1.08.1\Publish to Tableau Server.yxmc"

 

This is typically due to one of two reasons:

 

  1. The Publish to Tableau Server macro has not been installed on the Alteryx Server where the Gallery is located.
  2. The macro has been installed but has not been installed in the correct location, or the Gallery cannot access the macro for other reasons.

Please see this link for instructions on correctly installing the Publish to Tableau Server macro on an Alteryx Server.

 

Even when the macro has been installed properly on the server, this issue can still occur, and if it does, here is a simple workaround to get your workflow published:

 

  1. Save the workflow to the Gallery: From Designer, click on File > Save As and choose your Gallery.
  2. Add the Tableau macro components as assets of your workflow: Click on Workflow Options > Manage workflow assets.
  3. Select all of Publish to Tableau Server related assets (currently there are four).

Including these assets when publishing should allow the workflow to publish and run successfully in the Gallery.

 

Thank you!

Comments
Asteroid

Hey Dan, I've noticed that the workaround isn't working lately, because even if I try to select all four and package them up with my workflow, there are still errors because of all the "sub macros" that are in this tool.  Any suggestions?

Moderator
Moderator

Hi @Matt_Curtis!

 

Sorry to hear about that. Can you tell me what specific errors you are getting?

 

Thanks!

Asteroid

Hey @DanC. Sure, I've taken screenshots of each step, multiple screenshots of each since you can't see all the text on the save screen at once.

 

The problem stems from the fact that I'm including 4 assets while publishing:  Publish to Tableau Server, TableauServer.Selection.Projects, TableauServer.Selection.ServerSite, and TableauServer.Selection.Template.

 

Then I'm getting errors for the supporting sub-macros because the main macro is looking for them, but they aren't part of the package.  See screen caps for the names of each supporting macro.

 

tableauerror1.JPGtableauerror2.JPGtableauerror3.JPGtableauerror4.JPGtableauerror5.JPG

 

I'm sure I could go and find each of those macros and somehow include them as well, but I don't think that's how the tool was intended to work.

Asteroid

Hi DanC, 

 

I have exactly the same problem following your instruction step by step. Is there a resolution to this issue?

 

Regards

Henri

Same exact issue here as well. 

Asteroid

Hi all,

 

We recently had this issue at our organization as well and it turned out to have to do with the version of the macro we had installed on Server. (background: we are on Alteryx 2018.1 and Tableau 10.5.6)

 

We had the 1.09.version of the macro installed on our server, which was the most up to date version of the macro available at the time. Since then, that version was accidentally rolled back. Because of this, any user that installed the macro during the temporary rollback would have head the 1.09.1 version, leading to the "macro can't be found" errors. 

 

We talked to Alteryx about the accidental roll-back and they quickly got the 1.09.2 version back up and running in the macro district. For users having issues with the macro, I recommend reinstalling this version - and potentially having your server admin reinstall to the latest as well. Smiley Happy

 

Really hope this helps someone- I was spooked for awhile trying to understand why some workflows with the macro worked and others didn't!

Atom

Hi,

 

I am facing the same issue here. I am able to publish the tde file to tableau server, but unable to schedule a workflow through our Alteryx server.

I keep on getting the below error even after a fresh installation of my Alteryx designer.

 

Any idea please?Workflow error.JPGThank you

Asteroid

@ae2514 This error will occur when either 1) the PublishToTableauServer macro is not installed on server or 2) a different version is installed. You should verify with your server admin which version of the tool is supported in your environment (both Tableau and Alteryx servers) and make sure that is installed on your local machine and the server for all users (Dan outlines a few other workarounds/instructions on this original post). Hope this helps!

We are still working on Alteryx 11.7 and the compatible PublishToTableauServer package that I am using is version 1.08.1. I missed the 1.09.2 package. I have the 2.0.0 version but not compatible with alteryx 11.7. I got the same issue where supporting macros were missing even though i selected all 4 macros to be packaged when published. 

 

I found the following and this fixed my issue (its a workaround);

when publishing an app to the gallery the app is packaged and saved to your Alteryx Engine Workflow Directory. The packaged macros will be in the "_externals" folder. (Click anywhere on an open space of your workflow for the Workflow Configuration Property window, select the Workflow Tab, see 

 EngineWorkflowDirectoryC:\Users\username\AppData\Local\Temp\Staging\unique folder ID 

alteryx.PNG

 


When I opened the "_externals" folder it contained the 4 selected macros but not the supporting files. I had to copy the supporting files from the folder where the PublishToTableauServer tool was installed, to the staging folder of the published appalteryx.PNG

 

then saved app again, and it contained all the dependencies. 

Meteoroid

Thank you @StephanieVH, this solved the issue for me when I was trying to save the Macro to the server