Inspire EMEA 2022 On-Demand is live! Watch now, and be sure to save the date for Inspire 2023 in Las Vegas next May.

Alteryx Designer Ideas

Share your Designer product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines

Streaming Modules to run in sequence

I have several modules that need to run in sequence.   Can a ksh or some other program be used to string the modules together?  

So that if I have Step1.yxmd, Step2.yxmd and Step3.yxmd.  2 is dependent on 1, 3 is dependent on 2.  I want to tell it the jobs to run and then to wait until that module completes, then run the next.  


run Step1.yxmd
Wait

run Step2.yxmd
Wait

run Step3.yxmd
Wait


Or, if I have a group of modules that can run concurrently but subsequent jobs are dependent on all of them to finish, i can let all those jobs run and have the next step wait for those to complete to begin.  

run Step1A.yxmd
run Step1B.yxmd
run Step1C.yxmd
run Step1D.yxmd
Wait

run Step2.yxmd
Wait

run Step3.yxmd
Wait


I know this is very simplistic, but hoping it shows the need.  Also, we do have the scheduler set up to use, so if there is a way to set dependencies between modules within Scheduler, that might be helpful.  Just haven't found anything.  

Thanks!

23 Comments
sandeep_chayanam
8 - Asteroid
Hi Adam,

We tried the short term fix today, it worked for us too- thanks very much for that.

Fingers crossed for a long term fix!

Best,
Chris
AdamR
Alteryx
Alteryx
I've now fixed this issue and it will be in the Q4 release which should be out around December 18th.  If you would like the fix before then you just need to replace AlteryxRunner.exe with the new version which you can get from here https://github.com/AdRiley/ChaosReignsWithin-Alteryx-Macros/blob/master/Macros/SupportingExes/Altery... - Click "View Raw" to download and save it on top of the existing version in MacrosSupportingExes

Cheers
Adam
sandeep_chayanam
8 - Asteroid
Hi Adam,

Thank you very much for this fix. We will test it out and get back to you.

Thanks,
Sandeep.
rkallingal
5 - Atom
Hi Adam,

I'm pretty new Atlteryx space and may be carrying some of habits from other tools.

First of all thank you for great Runner macros and I believe it will help my project a great lot.

I was able to use use both Runner and Conditional Runner and execute modules in squence. However when I tried to use nested execution I get the following error message

Error - Alteryx Engine: The Feature ""API"" is not licensed.

Here are some more details. 
Module1
    Runner for Module 1.1
    Conditional Runner for Module 1.2

Module 1.1
    Runner for Module 1.1.1
    Runner for Module 1.1.2

Module 1.2
    Runner for Module 1.2.1
    Conditional Runner for Module 1.2.2

Both Module 1.1 & 1.2 executs successfully when run independanty. But get error when called using Runner/Conditional Runner from Module 1.

I would really appreciate if you have some time to take a look in to this and please let me know if you need any additional information or the module packages.

Thanks
Raj
jz
7 - Meteor

On V10 this Runner macro's are not working?

cbridges
11 - Bolide

@TaraMmaybe the status of this one should be "Now Available", as this is precisely what the Runner macros do. ;-)

Danilo_Amaral
5 - Atom

Hey Adam,

 

I'm Danilo, from Brazil and I'm having some trouble in using the Runner. Me and my colleagues always get the same error  The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741512. We've tried to look in Google this error code, but it was not helpful? Do you know what is this about?

 

Thanks!

 

 

TaraM
Alteryx
Alteryx

Hello @Danilo_Amaral

The crew macros were recently updated, so make sure you are running the latest:

http://community.alteryx.com/t5/Engine-Works-Blog/Crew-Macro-Pack-2016-Q2-Release/ba-p/26482

 

If you continue to run into issues, you could post your question in the discussion boards and you may get a quicker response from one of our community members:

http://community.alteryx.com/t5/Publishing-Gallery/bd-p/publishing-gallery

 

And remember, these macros are not 'officially' part of the product, so troubleshooting may require some trial and error.

http://www.chaosreignswithin.com/p/macros.html

cbridges
11 - Bolide

And if you still have problems, tag @AdamR. I'm sure he'd be happy to help. :-)

Danilo_Amaral
5 - Atom

Thanks a lot @TaraM and @cbridges, I'm still learning here in the Community. However, even with the update, the same error happens. @adamR do you know what it could be?

 

Kind Regards,