Alteryx Designer Ideas

Share your Designer product ideas - we're listening!

Proxy Server settings

I've done consulting at a number of client sites where the Alteryx Designer method of using IE proxy server settings isn't suitable.  Many enterprises are using automatic configuration scripts for the proxy server settings and this doesn't work with Alteryx Designer.  It is often not possible to explicitly set IE proxy server settings in an enterprise environment or in cases where it is possible those settings often revert back each night when group policies are synchronised. 

 

Ideally Alteryx Designer would be able to use automatic configuration scripts or have seperate proxy server configuration that can be configured in the application and not rely on settings in Internet Explorer or Windows.

1 Comment

If anyone else runs up against this... I was able to work around it by creating a GPO to use one of the client's specific proxy servers rather than the automatic configuration URL.  

 

Scenario: 

If Proxy settings in your domain are set using configuration by GPO using the settings under User Configuration \ Preferences \ Registry ----  HKLM\Software\Microsoft\Windows\CurrentVersion\Internet Settings  and one of those is that you use the AutoConfigURL, Alteryx will not use the Proxy server set by the auto configuration even though IE will be working properly.

 

Workaround:

*** Make sure you scope your GPO so that it only applies to the computer you want it to.  The GPO described below uses Machine Configuration settings which generally take precedence of User Configuration settings so you want to be sure you only apply this to the specific computer needing this setting.

To maintain control over the proxy settings but force a machine running Alteryx to use a "manually configured" proxy server you can create a new GPO that 

uses the Computer Configuration \ Preferences \ Windows Settings \ Registry settings and key path HKLM\Software\Microsoft\Windows\CurrentVersion\Internet Settings:

Add new registry configuration from with in Group Policy Management Editor at key path: HKLM\Software\Microsoft\Windows\CurrentVersion\Internet Settings  for the following values:

ProxyEnable REG_DWORD 1

ProxyOverride REG_SZ <local>

ProxyServer REG_SZ your.proxy.server:YourPort#

AutoDetect REG_DWORD 0   <---- this is an undocumented registry setting (google it)  0 turn auto configuration off.  Alteryx would not pick up the proxy server settings until "automatically detect settings" is disabled.