Alteryx Designer Ideas

Share your Designer product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

Azure Data Lake V2 Connectors

I have recently added an Azure data lake v2.   The Azure input/output connectors do not work with this version of the Azure data lake.


It appears that Alteryx adds "" to the file path.   This works for V1, but not needed for V2


any plans to configure a connector for Azure data lake v2?


Same here. Use for the data stream connector.

8 - Asteroid

i have written this macro in python which given following 6 inputs , it will download the file locally and then output the data 

the inputs it needs is 

Storage Account Name

Storage Account Key: you should be able to get it from Azure Portal 

Blob Container Name

Folder name where the file is within the Blob

File Name 

Local File Name : this is the location where the file will be downloaded , it can be a temporary location. 


as one time step you would  need to install a Azure library package which can be done inside the python tool using  the following line 


the macro is here


5 - Atom

Hi Anuj,


            Can you please provide more details on how to use the macro once it's installed successfully.


I ran into below error when ran Alteryx.installPackages("azure-storage-file-datalake") in python tool


CalledProcessError: Command '['c:\\program files\\alteryx\\bin\\miniconda3\\envs\\jupytertool_venv\\python.exe', '-m', 'pip', 'install', 'azure-storage-file-datalake']' returned non-zero exit status 1.


But when i ran from command prompt it installed successfully


C:\Program Files\Alteryx\bin\Miniconda3\envs\JupyterTool_vEnv>pip install azure-storage-file-datalake



Installing collected packages: azure-storage-file-datalake
Successfully installed azure-storage-file-datalake-12.0.1

8 - Asteroid

hi @srini2020  the requirement is only for that package to be installed. can you try this on the python tool 

from ayx import Alteryx


Alteryx has its own python virtual environment where the package should be installed. dont think installing it globally would help. 

you can try passing the parameters i mentioned in the above post and see if you get any errors. 


8 - Asteroid

@srini2020  if you are still unsuccessful installing the package you can try installing it from command line. instructions are in below thread


5 - Atom

@Anuj, I was able to install the package within Alteryx. I was having permission issues within C:\Program files so I reinstalled Alteryx Designer out of program files.



5 - Atom

Hi All


Any update in the ADL connector?


Hi @AdolfoLozano,


We're currently developing this connector and are hoping to include it in a near future release!

Alteryx Partner


5 - Atom

We also need this, as we'll be migrating from ADLS Gen 1 to ADLS Gen 2 shortly!