community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

shapefile output missing .shp file extension

Meteoroid

I'm using the create points tool to create a shapefile output using lat long coordinates from an csv input.  When I check the output folder all the files are there (.shx, .dbf, .prj) except the .shp file does not have an extension. Because of this when I go to add the file to an esri client it doesn't load in to the map.  I fixed it by manually renaming the individual file to add the .shp extension and it worked.  Obviously not an optimal solution, however.

 

Has anyone experienced this before?

 

Thanks in advance.

Jon

Alteryx Certified Partner

Did you save the results from a Browse tool, or use an Output tool to save the results? If you used an Output tool, you still need to enter the file extension as a part of the file path in addition to selecting the file type in the drop down in the Output tool configuration. In other words, enter "\filename.shp" in the file path and select "ESRI SHP file (*.shp)" in the drop down of the Output tool. 

Meteoroid

Perfect, thank you.  I missed that nuance. I'm used to working in ArcGIS where you don't always need to specify the extension.

 

Cheers!

Labels