Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

scheduler errors when manual run is successful when using Salesforce Input connectors

Sr. Community Content Manager
Sr. Community Content Manager

Thanks for the extra info. There was an issue with the download tool that was fixed in version that was causing timeout issues (see release notes). Since you're on 10.1 it doesn't seem like this should be the issue. If you can't get this worked out with customer support you could try using the deprecated Salesforce tool that doesn't rely on the download tool. To get to the deprecated version right-click on a blank section of the Connectors toolbar and click "Show Deprecated Tools".

Alteryx Partner

Hi Neil,


Yes I know about the deprecated tool, I was previously using that until the 10.1 as the v10 replacement of the deprecated tool was not proxy aware.

The latest version is the best version of the three that I have used.


I have been playing around with the time between scheduled jobs that use the salesforce connector. So instead of running the three workflows straight after each other (normally the first runs and the seond two fail) I have spacing them throughout the day. This has improved the success of the workflows. So whilst not ideal I can still get my jobs to run.


Without engaging the network team or salesforce team at the client site, My thoughts are that it is something to do with when the salesforce user login not being closed off quickly enough or cleared from queue once the download is complete. (apologies probably not the best technical description) 


To this end, I still think there are probably some improvements the alteryx can make to this tool. It is a little light weight and unreliable for me to use in a more business critical function.



Sr. Community Content Manager
Sr. Community Content Manager

If spreading your requests out helps then perhaps you are hitting a Salesforce API rate limit.


Thanks for your feedback. If you're able to get to the bottom of this with the Salesforce/network team at the client site (perhaps your Alteryx customer service rep can assist) then we'd love to hear the outcome to see if there's anything we can do to improve the product.

Alteryx Partner

Hi Neil,


reading the API request limit page I don't think this is the issue. 

I run 3 individual work flows that connect to Tasks, Events, Leads I take a full dowload of each of these tables and write them into SQL Server as they do not have a salesforce warehouse environment.

Total rows is less than 200K


This is super frustrating and as I've mentioned in string previously it is better in the latest version but still not great. Ideally the organistion would have salesforce data in the warehouse which I could connect to. Then I wouldn't use the Salesforce connector.

However that would take Alteryx off the hook so to speak.


I have previously raised this as an issue with Alteryx and was told the latest versions would fix it. But the issue persists. It's definately improved which is totally commendable but not at a level that I would consider reliable enough to be using the tool in a product environment which has a daily ETL component.



Sr. Community Content Manager
Sr. Community Content Manager

Thanks again for your feedback Scott. We are currently working on improvements to the Salesforce Input tool and will try to incorporate this scenario into our testing.

Alteryx Partner

Happy to test any changes you make the salesforce connect.